AR2200与S7706对接ospf邻居建立问题

发布时间:  2014-08-10 浏览次数:  270 下载次数:  0
问题描述
AR2200与S7706对接,配置OSPF,邻居无法建立。配置如下:

AR2200:

interface GigabitEthernet0/0/0
ip address 10.116.4.1 255.255.255.252
combo-port fiber
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/1.99
dot1q termination vid 99
ip address 10.115.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1.223
dot1q termination vid 223
ip binding vpn-instance VPN223
ip address 10.115.223.2 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface Cellular0/0/0
link-protocol ppp
#
interface Cellular0/0/1
link-protocol ppp
#
interface NULL0
#
interface LoopBack0
ip address 10.116.4.254 255.255.255.255
#
ospf 1
default-route-advertise always
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255
  network 10.116.4.254 0.0.0.0
#

S7706 :

interface Vlanif99
ip address 10.115.1.1 255.255.255.128
#
interface Vlanif223
ip address 10.115.223.1 255.255.255.0
#
interface Vlanif224
ip address 10.115.224.1 255.255.255.0
#
interface Vlanif500
ip address 10.115.220.1 255.255.255.0
#
.....
ospf 1
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255
#

无邻居建立
[RT-EG-Huawei-PoC]display ospf 1 peer

[RT-EG-Huawei-PoC]display ospf 1 interface

         OSPF Process 1 with Router ID 10.116.4.1
                 Interfaces

Area: 0.0.0.0          (MPLS TE not enabled)
IP Address      Type         State    Cost    Pri   DR              BDR
10.116.4.254    P2P          P-2-P    0       1     0.0.0.0         0.0.0.0
10.115.1.2      Broadcast    DR       1       1     10.115.1.2      0.0.0.0

[Cor-SW-Huawei-PoC]display ospf 1 peer

[Cor-SW-Huawei-PoC]display ospf 1 interface

         OSPF Process 1 with Router ID 10.115.1.1
                 Interfaces

Area: 0.0.0.0          (MPLS TE not enabled)
IP Address      Type         State    Cost    Pri   DR              BDR
10.115.1.1      Broadcast    DR       1       1     10.115.1.1      0.0.0.0
告警信息
处理过程
更改vlanif99的ip地址掩码为24位,

interface Vlanif99
ip address 10.115.1.1 255.255.255.0

问题解决。
根因
查看其ospf相关配置和接口配置,发现:

AR 侧:
ospf 1
default-route-advertise always
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255 
  network 10.116.4.254 0.0.0.0

interface GigabitEthernet0/0/1.99
dot1q termination vid 99
ip address 10.115.1.2 255.255.255.0

交换机侧:

ospf 1
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255 

interface Vlanif99
ip address 10.115.1.1 255.255.255.128   --- 对端配置的掩码为24位,ospf通告的网段也为24位,这里ospf通告的网段与对端一致,掩码也是24未,单配置的IP地址掩码却是25位。

推测是两侧IP地址掩码配置不一致,导致ospf邻居检查失败无法建立邻居关系。

打开ospf debug开关,发现如下debug信息:

Jun  5 2014 14:29:35+00:00 RT-EG-Huawei-PoC OSPF/2/IFCFGERR:OID 1.3.6.1.2.1.14.16.2.4: A packet is received on the non-virtual interface from a router whose configuration conflicts with the local configuration. (IfIpAddress=10.115.1.2, AddressLessIf=0, ProcessId=1, RouterId=10.116.4.1, PacketSrc=10.115.1.1, ConfigErrorType=7, PacketType=1, InstanceName=)
<RT-EG-Huawei-PoC>
<RT-EG-Huawei-PoC>
<RT-EG-Huawei-PoC>
Jun  5 2014 14:29:44+00:00 RT-EG-Huawei-PoC OSPF/2/IFCFGERR:OID 1.3.6.1.2.1.14.16.2.4: A packet is received on the non-virtual interface from a router whose configuration conflicts with the local configuration. (IfIpAddress=10.115.1.2, AddressLessIf=0, ProcessId=1, RouterId=10.116.4.1, PacketSrc=10.115.1.1, ConfigErrorType=7, PacketType=1, InstanceName=)
<RT-EG-Huawei-PoC>
Jun  5 2014 14:29:54+00:00 RT-EG-Huawei-PoC OSPF/2/IFCFGERR:OID 1.3.6.1.2.1.14.16.2.4: A packet is received on the non-virtual interface from a router whose configuration conflicts with the local configuration. (IfIpAddress=10.115.1.2, AddressLessIf=0, ProcessId=1, RouterId=10.116.4.1, PacketSrc=10.115.1.1, ConfigErrorType=7, PacketType=1, InstanceName=)
<RT-EG-Huawei-PoC>
Jun  5 2014 14:30:04+00:00 RT-EG-Huawei-PoC OSPF/2/IFCFGERR:OID 1.3.6.1.2.1.14.16.2.4: A packet is received on the non-virtual interface from a router whose configuration conflicts with the local configuration. (IfIpAddress=10.115.1.2, AddressLessIf=0, ProcessId=1, RouterId=10.116.4.1, PacketSrc=10.115.1.1, ConfigErrorType=7, PacketType=1, InstanceName=)
<RT-EG-Huawei-PoC>

证明之前判断正确。
建议与总结
在排查ospf问题时,可以从ip地址及掩码,ospf进程号,ospf发布网段,ospf hello时间参数配置等几个方面入手排查。

END