华为S5300无法与友商思科交换机成功协商LACP

发布时间:  2014-09-02 浏览次数:  668 下载次数:  0
问题描述
          
现象描述:现网华为S5300交换机无法与友商思科设备3560G成功协商LACP
设备相关信息如下:
思科:3560G
华为:S5300
思科G0/25---华为G0/0/1
思科G0/27---华为G0/0/2
告警信息
处理过程
思科:3560G
华为:S5300
思科G0/25---华为G0/0/1
思科G0/26---华为G0/0/2

华为交换机
#interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
mode lacp-static    //修改链路聚合模式
max active-linknumber 2   //设置最大活动链接数为2
bpdu enable        //开启BPDU
#lacp priority 100
#interface GigabitEthernet0/0/1
eth-trunk 1
undo ntdp enable
undo ndp enable
(在配置端口前,一定要将端口原有配置清空,全部undo掉,否则无法应用eth-trunk命令。如果之前端口配置过trunk口,可以使用undo port link-type清除trunk状态)
#interface GigabitEthernet0/0/2
eth-trunk 1
undo ntdp enable
undo ndp enable
思科交换机
interface port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface g0/25
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface g0/26
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
根因
1,链路问题。2,配置问题。
建议与总结
华为交换机配置链路聚合有两种模式,分别是manual和lacp-static,如果不做配置,交换机默认是manual,所以一定要手动将模式改为lacp-static,这点很重要,否则无法跟思科交换机成功协商LACP。

END