IPCC产品V300R005C05版本邮件报警功能出现对接异常

发布时间:  2014-09-10 浏览次数:  201 下载次数:  10
问题描述
邮件报警后坐席没有收到报警,在cccbar上可以看到有邮件报警进来,但是没有邮件处理框(如上图)跳出来,截图如下:
告警信息
处理过程
a.与之前环境比较发现在mailm服务器配置中勾选了SSL,将SSL去掉后检查邮箱,发现报错如下

     b.此时将SSL勾选上,此报错消失

     c.初步定位是SSL导致的问题,之前的正常环境是邮件服务器跟mailm服务器都没有使用SSL,两边都统一所以没有问题。考虑到后续的exchange版本都需要加入SSL(出于安全考虑),所以我们这里也需要跟exchange服务器同步,使用SSL
   d.通过实验发现需要在exchange新增加接受连接器才可以让使用SSL的mailm服务器正常收发邮件,操作截图如下(以exchange2010为例,exchange2013同理)。先点击hub transport,在下面新建接受连接器

双击打开新建的连接器,配置如下


根因
原因分析:
1.由于之前没有遇到过这样的情况,猜测可能是环境变化引起的
    2.排查比较不同环境,找到不同点
    3.尝试还原环境观察问题是否复现,进一步定位问题

邮件报警功能实现原理:
1. 邮件客户端(或者邮箱用户通过网页登入)发送报警信息到政府开放的公共报警邮箱(比如police@laopcc2.com)进行报警。下图是通过网页登入(使用测试账号test01报警)

公共报警邮件需要在was维护

2. 在CTI配置邮件技能,使用邮箱为开放的公共邮箱。(此时公共邮箱作为统一报警接入)。当收到邮件报警时CTI将此报警事件加入到邮件技能队列排队。邮件服务通过SMTP跟POP3协议实现邮件互通

3. 当有空闲坐席时(此坐席需要有邮件技能)将队列中的邮件报警分配到该坐席。(需要事先配置该坐席的个人收件箱、发件箱)

4. 坐席收到报警,并且可以直接回复

解决方案
通过修改exchange配置跟WAS中吻合即可
建议与总结
1.exchange目前只有2010版本跟IPCC系统对接过,2013版本还没有正式对接过
   2.只在接受端POP3服务器加SSL即可,SMTP服务器没有必要加SSL
   3. 在was配置时可以通过check mailbox来验证邮箱是否有效

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