AR2220不能学习到ospf路由

发布时间:  2014-10-06 浏览次数:  239 下载次数:  0
问题描述

县局路由器AR2220显示ospf邻居full,
[xianju_AR2220]display ospf peer brief

  OSPF Process 1 with Router ID 2.2.2.2
    Peer Statistic Information
----------------------------------------------------------------------------
Area Id          Interface                        Neighbor id      State   
0.0.0.0          GigabitEthernet0/0/0             1.1.1.1          Full       
----------------------------------------------------------------------------

但是没有学习到ospf路由
[xianju_AR2220]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 8        Routes : 8       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
       10.0.0.0/30  Direct  0    0           D   10.0.0.2        GigabitEthernet0
/0/0
       10.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0
/0/0
       10.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0
/0/0
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0


市局配置
<shiju_NE40-X3>system-view
Enter system view, return user view with Ctrl+Z.
[shiju_NE40-X3]dis cu
[shiju_NE40-X3]dis current-configuration
[V200R003C00]
#
sysname shiju_NE40-X3
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone Indian Standard Time minus 05:13:20
clock daylight-saving-time Day Light Saving Time repeating 12:32 9-1 12:32 11-23
00:00 2005 2005
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.0.0.1 255.255.255.252
ospf network-type p2p
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
ospf 1 router-id 1.1.1.1
area 0.0.0.0
  network 1.1.1.1 0.0.0.0
  network 10.0.0.0 0.0.0.3
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return



县局配置
<xianju_AR2220>dis current-configuration
[V200R003C00]
#
sysname xianju_AR2220
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone Indian Standard Time minus 05:13:20
clock daylight-saving-time Day Light Saving Time repeating 12:32 9-1 12:32 11-23
00:00 2005 2005
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.0.0.2 255.255.255.252
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
ospf 1 router-id 2.2.2.2
area 0.0.0.0
  network 2.2.2.2 0.0.0.0
  network 10.0.0.0 0.0.0.3
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#

处理过程
        由于市局和县局直接连接的是mstp专线,市局路由器NE40-X3连接县局AR2220接口早就已经配置成了p2p的ospf接口类型
而县局的路由器上还是默认的broadcast,所以就会显示ospf邻居能够建立起来,但是不能学习到ospf路由,所以解决的办法就是
将县局AR2220路由器的接口也改成p2p的类型就可以了

解决方案
      在进行网络配置之前,还是建议大家多详细看看配置脚本,这样就可以避免很多问题的发生,
在ospf网络中,我们认为一般出现ospf邻居建议起来就一定会有ospf路由,事实上不是这样的,当
两端的ospf接口类型不一致的时候就会出现邻居full,但是不能学习到路由的情况

END