FAQ-如何处理由于Linux主机操作系统版本与内核版本不匹配导致的安装多路径时提示“未知的内核”的问题

发布时间:  2014-10-10 浏览次数:  96 下载次数:  0
问题描述
如何处理由于Linux主机操作系统版本与内核版本不匹配导致的安装多路径时提示“未知的内核”的问题?

解决方案
在装多路径软件时,如果该软件包适用的内核和实际的操作系统信息不匹配,则会提示“未知的内核”。

1、运行cat cat /etc/xxx-release(xxx代表Linux发行版的名称,例如:redhat、SuSE等)查询操作系统版本。
# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)

2、运行uname -a查询Linux系统的内核版本号。
# uname -a
Linux ctucipjrlx007 2.6.9-78.ELsmp #1 SMP Sat Nov 26 08:44:12 CST 2011 i686 i686 i386 GNU/Linux

3、按照表1所示的内容确认操作系统版本与内核版本是否一致。
表1 操作系统版本与内核版本对应关系 



4、如果不一致请将“/etc/xxx-release”中的系统版本信息修改为表1内核版本相应的操作系统版本信息后,再进行安装。

END