FAQ-三层交换机与路由器组网实现internet访问的配置举例

发布时间:  2015-02-13 浏览次数:  1153 下载次数:  209
问题描述
三层交换机做为内网网关,通过路由器来上网。

需要考虑设备间的路由。
解决方案
1.  组网图

2.  配置思路

交换机:作为网关,配置内网的服务,又需要将引导内网访问外网的数据

路由器:作NAT转换,同时引导返回流量正确地回到内网中

交换机的重点配置:

a.创建好相关vlan,配置vlan的ip,并加入接口
sys
vlan batch 10 20 100
interface Vlanif10
ip address 192.168.1.1 255.255.255.0   //作为网关
interface Vlanif20
ip address 192.168.2.1 255.255.255.0
interface Vlanif100
ip address 192.168.100.2 255.255.255.0

interface Ethernet0/0/3   //以Access的方式加入接口,下联pc
port link-type access
port default vlan 10
interface Ethernet0/0/2
port link-type access
port default vlan 20
interface Ethernet0/0/1
port link-type access
port default vlan 100
quit

b.内网的DHCP服务
dhcp enable
interface Vlanif10                                       //使用接口的ip作网关 掩码作dhcp网段,设置DNS。
dhcp select interface
dhcp server dns-list 114.114.114.114 223.5.5.5      //公共DNS,全国均可使用,不区分ISP
interface Vlanif20
dhcp select interface
dhcp server dns-list 114.114.114.114 223.5.5.5
quit

c.添加路由
ip route-static 0.0.0.0 0.0.0.0 192.168.100.1             //重点,加了才能上外网

路由器的重点配置:
a.配置接口ip地址
interface GigabitEthernet0/0/0
ip address 192.168.100.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 200.0.0.2 255.255.255.0 

b.启用NAT功能
acl number 2001                                 //此ACL用于限定NAT转换的数据
rule 5 permit 
quit
interface GigabitEthernet0/0/1
nat outbound 2001                           //开启NAT功能
quit

c.添加路由
ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
ip route-static 192.168.0.0 255.255.0.0 192.168.100.2   //重要,回程路由,数据才能返回到内网

END