a secondary LTE card with SIM did not get IP address in AR1200

Publication Date:  2014-12-02 Views:  630 Downloads:  0
Issue Description
A customer found that a secondary LTE card with SIM didn’t get IP address in AR1200, but the first WCDMA card in the same AR could get IP address.
This is the topology:

There are two AR-1LTE-L-S cards in this AR1200. But the customer didn’t use any LTE card as backup interface.
The customer inserted a 3G SIM card in the first AR-1LTE-L-S card, so it connected to WCDMA network, and got IP address. But the second AR-1LTE-L-S card with LTE SIM card didn’t get IP address.
Alarm Information
None
Handling Process
(1) Check the configuration for interface Cellular1/0/0 and Cellular2/0/0, they turn out same, and the key configuration is done.
#
interface Cellular1/0/0
tcp adjust-mss 1200
dialer enable-circular
dialer-group 1
apn-profile lteprofile
dialer number *99#
nat outbound 3001
ip address negotiate
#
interface Cellular2/0/0
tcp adjust-mss 1200
dialer enable-circular
dialer-group 1
apn-profile lteprofile
dialer number *99#
nat outbound 3001
ip address negotiate
#
dialer-rule
dialer-rule 1 ip permit
#
apn profile lteprofile
apn testxx
#

(2)  Check the output of this command: [Huawei]display Cellular. From the output, we can see SIM card in Cellular2/0/0 was attached to PS domain in LTE network. But we found this strange situation that Cellular1/0/0 had the APN, but Cellular2/0/0 didn’t have any APN. But from the related configuration in Step(1), we can see the configuration for Cellular1/0/0 and Cellular2/0/0 was same. 

We learnt that if an interface had never dialed up, that you can’t see APN information from the command “display Cellular”. Then we should find out why Cellular never dialer?
(3) Since no “autodial” parameter was configured in “dialer number” command, so Cellular1/0/0  and Cellular2/0/0 were not permanently online, the link establishment was triggered by traffic. We went back to the topology and the configuration. In the configuration, we can see these two default route:
#
ip route-static 0.0.0.0 0.0.0.0 100.x.y.2 preference 30  
ip route-static 0.0.0.0 0.0.0.0 Cellular1/0/0 preference 100
#

Check the statue of G0/0/1, and found it was down.
GigabitEthernet0/0/1 current state : DOWN
Line protocol current state : DOWN
Description:This interface connects to Internet
Route Port,The Maximum Transmit Unit is 1500
Internet Address is 100.x.y.1/30
So all the traffic would go though Cellular1/0/0. That was why it dial in this interface Cellular1/0/0. But no traffic went though Cellular2/0/0, so there was no APN in “display Cellular 2/0/0 all” and no ip address.
Root Cause
(1) In the configuration “dialer number *99#’ in interface Cellular2/0/0, no “autodial” parameter.
(2) No traffic triggered  link establishment in Cellular2/0/0.
Solution
1. Change the configuration as below, then Cellular2/0/0 will be permanently online, for it will automatic dial-up .
interface Cellular2/0/0
……
dialer number *99 autodial
After this parameter is added, the LTE Card in Cellular2/0/0 can get IP address.

2. Add another default route:
ip route-static 0.0.0.0 0.0.0.0 Cellular2/0/0 preference 120
Then when the interface Cellular1/0/0 is down, all the traffic will go though Cellular2/0/0.

3. If the customer hope that all the traffic go through LTE network instand of WCDMA netowrk, then change the preference of this route:
ip route-static 0.0.0.0 0.0.0.0 Cellular2/0/0 preference 80

Suggestions
1. For 3G card or LTE card, when you configure the command “dialer number *99”, make sure they sometimes traffic will go though the related Cellular interface, or it will not dial never. 

END