ac6605双链路热备

发布时间:  2014-12-01 浏览次数:  320 下载次数:  0
问题描述
ac6605 双链路热备

组网拓扑如下:




AC1配置如下:

 sysname AC1
#
vlan batch 2
#
hsb-service-type access-user hsb-service 0
#
hsb-service-type ap hsb-service 0
#
diffserv domain default
#
pki realm default
enrollment self-signed
#
interface Vlanif1
ip address 192.168.1.1 255.255.255.0
#
interface MEth0/0/1
#
interface XGigabitEthernet0/0/1
auto speed 10 100 1000
#
interface XGigabitEthernet0/0/2
auto speed 10 100 1000
#
interface Wlan-Ess0
port hybrid pvid vlan 2
port hybrid untagged vlan 2
#
interface NULL0
#
hsb-service 0
service-ip-port local-ip 192.168.1.1 peer-ip 192.168.1.2 local-data-port 10241 p
eer-data-port 10241
service-keep-alive detect retransmit 3 interval 1
#
wlan
wlan ac source interface vlanif1
wlan ac protect enable protect-ac 192.168.1.2 priority 2
ap id 1 type-id 19 mac 00e0-fcc8-3d00 sn 210235448310A853DE5F
wmm-profile name wm id 0
traffic-profile name tp id 0
security-profile name sp id 0
service-set name ss id 0
  wlan-ess 0
  ssid 123456
  traffic-profile id 0
  security-profile id 0
  dhcp snooping
  service-vlan 2
radio-profile name rp id 0
  wmm-profile id 0
ap 1 radio 0
  radio-profile id 0
  service-set id 0 wlan 1

#
return

AC2的配置如下:

#
sysname AC2
#
vlan batch 2
#
hsb-service-type access-user hsb-service 0
#
hsb-service-type ap hsb-service 0
#
diffserv domain default
#
pki realm default
enrollment self-signed
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default 
domain default_admin 
local-user admin password cipher %@%@*bo]Dnyrm1\x`qC3g=d;3Uw}%@%@
local-user admin service-type http
#
interface Vlanif1
ip address 192.168.1.2 255.255.255.0
#
interface MEth0/0/1
#
interface XGigabitEthernet0/0/1
auto speed 10 100 1000
#
interface XGigabitEthernet0/0/2
auto speed 10 100 1000
#
interface Wlan-Ess0
port hybrid pvid vlan 2
port hybrid untagged vlan 2
#
interface NULL0
#
hsb-service 0
service-ip-port local-ip 192.168.1.2 peer-ip 192.168.1.1 local-data-port 10241 p
eer-data-port 10241
service-keep-alive detect retransmit 3 interval 1
#
wlan
wlan ac source interface vlanif1
wlan ac protect enable protect-ac 192.168.1.1 priority 5
ap id 1 type-id 19 mac 00e0-fcc8-3d00 sn 210235448310A853DE5F
wmm-profile name wm id 0
traffic-profile name tp id 0
security-profile name sp id 0
service-set name ss id 0
  wlan-ess 0
  ssid 123456
  traffic-profile id 0
  security-profile id 0
  dhcp snooping
  service-vlan 2
radio-profile name rp id 0
  wmm-profile id 0
ap 1 radio 0
  radio-profile id 0
  service-set id 0 wlan 1

#
return  请确认主备ac的业务配置完全一致

交换机为基本配置略


解决方案
ap上线成功 无线业务下发到ap

登陆ap查看capwap 链路信息:

<ap-1>display capwap link state


------------------------------------------------------------------------------
LINK                                      AP    AP    AP     InIf          FSM
   ID                                  IPAddr CPort DPort    Index        State
------------------------------------------------------------------------------
    0                           254.1.168.192 51075 51076        0          RUN
    1                           192.168.1.254 49337 49338        0          RUN
------------------------------------------------------------------------------

<ap-1>display capwap link-detailed-info linkid 0


------------------------------------------------------------------------------
LinkID        : 0
AP State      : RUN
IP VERSION    : 4
AP IPAddr     : 254.1.168.192
AC IPAddr     : 192.168.1.1
AP ControlPort: 51075
AP DataPort   : 51076
AP Type       : AP6010DN-AGN
AP Macaddress : 00e0-fcc8-3d00
AP Sn         : 210235448310A853DE5F
AP DataFwdMode: 0
AP InIfIndex  : 0
AP LastState  : DATA_CHECK
AP SessionID  : c8fce000-607003d-42d18feb-6504b034
Sesstion timer : 0
DataCheckTimer timer : 0
EchoIntervalTimer timer : 21
ResetTimer timer : 0
KeepAliveTimer timer : 0
dtls state : 0
DiscoveryTimer timer : 20
RevertiveTimer timer : 0
Active LinkId : 0
Primary LinkId : 0
Config Flag : 1
Start ProtectLink : 1
Double Link Switch : 1
Discovery times : 0
TearDown times : 0
AC Num : 1
AC MAC : 00e0-fc17-2672
------------------------------------------------------------------------------
<ap-1>display capwap link-detailed-info linkid 1


------------------------------------------------------------------------------
LinkID        : 1
AP State      : RUN
IP VERSION    : 4
AP IPAddr     : 192.168.1.254
AC IPAddr     : 192.168.1.2
AP ControlPort: 49337
AP DataPort   : 49338
AP Type       : AP6010DN-AGN
AP Macaddress : 00e0-fcc8-3d00
AP Sn         : 210235448310A853DE5F
AP DataFwdMode: 0
AP InIfIndex  : 0
AP LastState  : DATA_CHECK
AP SessionID  : c8fce000-a871003d-a857e724-20a1b37c
Sesstion timer : 0
DataCheckTimer timer : 0
EchoIntervalTimer timer : 1
ResetTimer timer : 0
KeepAliveTimer timer : 0
dtls state : 0
DiscoveryTimer timer : 20
RevertiveTimer timer : 0
Active LinkId : 0
Primary LinkId : 0
Config Flag : 1
Start ProtectLink : 1
Double Link Switch : 1
Discovery times : 0
TearDown times : 0
AC Num : 1
AC MAC : 00e0-fc12-5267    / 可以看到ap同时和主备ac都建立了capwap 链路



查看hsb的状态:

[AC1]display hsb-service 0
Hot Standby Service Information:
----------------------------------------------------------
  Local IP Address       : 192.168.1.1
  Peer IP Address        : 192.168.1.2
  Source Port            : 10241
  Destination Port       : 10241
  Keep Alive Times       : 3
  Keep Alive Interval    : 1
  Service State          : Connected
  Service Batch Modules  : Access-user
                           AP
----------------------------------------------------------


[AC2]display hsb-service 0
Hot Standby Service Information:
----------------------------------------------------------
  Local IP Address       : 192.168.1.2
  Peer IP Address        : 192.168.1.1
  Source Port            : 10241
  Destination Port       : 10241
  Keep Alive Times       : 3
  Keep Alive Interval    : 1
  Service State          : Connected
  Service Batch Modules  : AP
                           Access-user
----------------------------------------------------------

在主AC上查看ap的状态:

[AC1]display ap  all
  All AP information(Normal-1,UnNormal-0):
  ------------------------------------------------------------------------------
  AP    AP                    AP              Profile   AP              AP
    /Region
  ID    Type                  MAC             ID        State           Sysname
  ------------------------------------------------------------------------------
  1     AP6010DN-AGN          00e0-fcc8-3d00    0/0     normal          ap-1
  ------------------------------------------------------------------------------
  Total number: 1

在备AC上查看ap状态:

[AC2]display ap  all
  All AP information(Normal-0,UnNormal-1):
  ------------------------------------------------------------------------------
  AP    AP                    AP              Profile   AP              AP
    /Region
  ID    Type                  MAC             ID        State           Sysname
  ------------------------------------------------------------------------------
  1     AP6010DN-AGN          00e0-fcc8-3d00    0/0     standby         ap-1
  ------------------------------------------------------------------------------
  Total number: 1


主ac查看接入终端的信息

[AC1]display  access-user
------------------------------------------------------------------------------
UserID Username                       IP address                   MAC 
------------------------------------------------------------------------------
18     548998e820af                   -                         5489-98e8-20af
------------------------------------------------------------------------------
Total 1,1 printed

备AC上查看终端接入状态:

[AC2]display access-user
------------------------------------------------------------------------------
UserID Username                       IP address                   MAC 
------------------------------------------------------------------------------
18     548998e820af                   -                         5489-98e8-20af
------------------------------------------------------------------------------
Total 1,1 printed


通过以上查看信息  可以确认双链路热备配置成功  ap和终端用户信息  同步正常。

总结:双链路热备最要 注意双链路和热备这两个方面  通过hsb协议实现两台ac上 ap和接入终端的信息同步 
双链路可以登录ap进行查看确认是否建立成功
双机热备只能同步状态和会话信息 所以ap上线和无线业务配置在两台ac设备上一定要保持一致

END