AR2220设备子接口互联某子接口不通

发布时间:  2014-12-11 浏览次数:  180 下载次数:  0
问题描述
问题描述:AR2220设备做为内网多个vlan用户的网关,测试发现AR2220设备作为vlan 1的网关时,vlan1用户无法访问网络资源。
网络拓扑:

部分配置如下:
交换机G0/0/1口配置
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 3
路由器G0/0/2口配置:
interface Ethernet0/0/2.1
dot1q termination vid 1
ip address 192.168.10.1 255.255.255.0
arp broadcast enable
#
interface Ethernet0/0/2.2
dot1q termination vid 2
ip address 192.168.20.1 255.255.255.0
arp broadcast enable

interface Ethernet0/0/2.3
dot1q termination vid 3
ip address 192.168.30.1 255.255.255.0
arp broadcast enable


处理过程
测试发现client1不能ping通网关地址192.168.10.1,在接口上抓包发现client1发送的icmp报文是不带vlan 标签,怀疑是不带vlan标签的数据发送到AR2220设备的子接口上无法识别导致报文被丢弃。修改交换机配置如下:
新建未使用的vlan4,接口修改为:
interface GigabitEthernet0/0/1
port link-type trunk
port trunk pvid vlan 4
port trunk allow-pass vlan 2 to 3
测试发现client1通信正常
根因
在使用路由器作为内网多个vlan 网关时,不要使用缺省vlan 通信,由于缺省vlan在数据通信过程中不带vlan标签,在路由器上无法根据vlan tag区分不通的子接口,导致数据通信异常。
建议与总结
交换机缺省vlan是vlan 1,建议在现网中尽量避免使用vlan 1,而使用其他的vlan来替代vlan1。

END