FAQ-AR路由器重定向+NQA配置方法

发布时间:  2014-12-27 浏览次数:  689 下载次数:  4
问题描述
AR1200路由器作为出口路由器,双上行出口,走两个运营商出公网。
要求:
1、内网用户分为两大组,一组走ISP1,另一组走ISP2;
2、要求在链路上检查连通性,当某一条出口故障时,自动切换到另一出口。
解决方案
<Huawei>sys    //进入系统会话视图
基础配置(可选)

[Huawei]         //给内网两个网段创建VLANIF接口
[Huawei]vlan 10
[Huawei-vlan10]int vlan 10
[Huawei-Vlanif10]ip add 192.168.10.1 255.255.255.0
[Huawei-Vlanif10]q
[Huawei]vlan 20
[Huawei-vlan20]int vlan 20
[Huawei-Vlanif20]ip address 192.168.20.1 255.255.255.0
[Huawei-Vlanif20]q
[Huawei]         //将面向内网的1-3口批量划分进VLAN10,4-6批量划分进VLAN20
[Huawei]interface range Ethernet 0/0/1 to Ethernet 0/0/3
[Huawei-port-group]port link-type access
[Huawei-port-group]port default vlan 10
[Huawei-port-group]q
[Huawei]interface range Ethernet 0/0/4 to Ethernet 0/0/6
[Huawei-port-group]port link-type access
[Huawei-port-group]port default vlan 20
[Huawei-port-group]q
[Huawei]          //连接到运营商的外网出接口
[Huawei]int GigabitEthernet 0/0/0
[Huawei-GigabitEthernet0/0/0]ip add 100.0.1.2 255.255.255.0
[Huawei-GigabitEthernet0/0/0]q
[Huawei]int GigabitEthernet 0/0/1
[Huawei-GigabitEthernet0/0/1]ip add 200.0.2.2 255.255.255.0
[Huawei-GigabitEthernet0/0/1]q
[Huawei]ip route-static 0.0.0.0 0.0.0.0 100.0.1.1          //指向isp1出接口的默认路由
[Huawei]ip route-static 0.0.0.0 0.0.0.0 200.0.2.1 preference 65    //指向isp2出接口的默认路由,建议将两条默认路由的优先级设置为不同的值,以避免两条等价路由导致HASH负载均衡而产生的网速慢的情况,缺省为60.

重定向部分

[Huawei]acl 2010            //创建ACL,用于强制重定向到isp1的VLAN10的10.0网段进行ACL匹配
[Huawei-acl-basic-2010]rule permit source 192.168.10.0 0.0.0.255
[Huawei-acl-basic-2010]q
[Huawei]acl 2020            //创建ACL,用于强制重定向到isp1的VLAN10的10.0网段进行ACL匹配
[Huawei-acl-basic-2020]rule permit source 192.168.20.0 0.0.0.255
[Huawei-acl-basic-2020]q
[Huawei]traffic classifier isp1         //为isp1出口建立流分类,将之前的ACL2010挂入
[Huawei-classifier-isp1]if-match acl 2010
[Huawei-classifier-isp1]q
[Huawei]traffic classifier isp2        //为isp2出口建立流分类,将之前的ACL2020挂入
[Huawei-classifier-isp2]if-match acl 2020
[Huawei-classifier-isp2]q
[Huawei]traffic behavior isp1             //为isp1出口建立流行为,用于重定向到isp1的网关
[Huawei-behavior-isp1]redirect ip-nexthop 100.0.1.1
[Huawei-behavior-isp1]q
[Huawei]traffic behavior isp2            //为isp2出口建立流行为,用于重定向到isp2的网关
[Huawei-behavior-isp2]redirect ip-nexthop 200.0.2.1
[Huawei-behavior-isp2]q
[Huawei]traffic policy isp1           //为isp1出口建立流策略,将之前创建的用于isp1的流分类和流行为进行捆绑
[Huawei-trafficpolicy-isp1]classifier isp1 behavior isp2
[Huawei-trafficpolicy-isp1]q
[Huawei]traffic policy isp2           //为isp2出口建立流策略,将之前创建的用于isp2的流分类和流行为进行捆绑
[Huawei-trafficpolicy-isp2]classifier isp2 behavior isp2
[Huawei-trafficpolicy-isp2]q
[Huawei]int vlan 10           //在面向内网的VLANIF10接口上调用之前创建的流策略isp1,这样就可以使从这个接口进入的数据,匹配ACL后,执行流行为强制跳转到isp1的运营商网关
[Huawei-Vlanif10]traffic-policy isp1 inbound
[Huawei-Vlanif10]q
[Huawei]int vlan 20           //在面向内网的VLANIF20接口上调用之前创建的流策略isp2,这样就可以使从这个接口进入的数据,匹配ACL后,执行流行为强制跳转到isp2的运营商网关
[Huawei-Vlanif20]traffic-policy isp2 inbound
[Huawei-Vlanif20]q
[Huawei]                         //重定向是要依赖于路由表项的,要有生效的路由表项,重定向功能才能生效。
[Huawei]                           如果没有对应的生效路由表项,重定向将无效,按照其他可达目的地的路由表项进行转发。

NQA部分

[Huawei]nqa test-instance huawei isp1         //创建NQA测试实例,用于探测isp1的链路
[Huawei-nqa-huawei-isp1]test-type icmp              //探测类型为icmp
[Huawei-nqa-huawei-isp1]destination-address ipv4 110.0.1.1          //探测目标地址为110.0.1.1,这个地址要是属于isp1的地址,必须要从isp1出口出去。
[Huawei-nqa-huawei-isp1]source-interface GigabitEthernet 0/0/0      //指定从G0/0/0 ISP1的接口发出探测包
[Huawei-nqa-huawei-isp1]frequency 60              //设置探测时间间隔
[Huawei-nqa-huawei-isp1]start now        //设置为立即开始探测
[Huawei-nqa-huawei-isp1]q
[Huawei]               //用于探测isp2的NQA实例,配置方法和isp1相同
[Huawei]nqa test-instance huawei isp2
[Huawei-nqa-huawei-isp2]test-type icmp
[Huawei-nqa-huawei-isp2]destination-address ipv4 220.0.2.2
[Huawei-nqa-huawei-isp2]source-interface GigabitEthernet 0/0/1
[Huawei-nqa-huawei-isp2]frequency 60
[Huawei-nqa-huawei-isp2]start now
[Huawei-nqa-huawei-isp2]q
[Huawei]ip route-static 0.0.0.0 0.0.0.0 100.0.1.1 track nqa huawei isp1           //在之前的默认路由上捆绑NQA实例,当NQA探测失效时,会联动该路由失效。
[Huawei]ip route-static 0.0.0.0 0.0.0.0 200.0.2.1 preference 65 track nqa huawei isp2
[Huawei]ip route-static 110.0.1.1 255.255.255.255 100.0.1.1      //添加一条指向到NQA测试目的地址的明细路由,这样当链路恢复时,NQA也会恢复探测
[Huawei]ip route-static 220.0.2.2 255.255.255.255 200.0.2.1
[Huawei]q
<Huawei>

END