E9000交换板CX110&CX310配置脚本与说明

发布时间:  2014-12-28 浏览次数:  1437 下载次数:  1159
问题描述
E9000复杂的内部架构与组网配置,给相关项目实的施带来不少障碍,特别是给一些初接触E9000的工程师造成很大困难。所以,本案例基于两次涉及E9000的项目经验,以CX110+MZ110+CH121组网配置为例对交换板内部架构与配置方式进行详细说明,希望帮助初接触E9000的工程师快速上手,排除项目实施中的一大障碍。
告警信息
处理过程
CX110+MZ110+CH121组网图

CX110交换板配置
1. 配置堆叠特性
2. 配置上行链路聚合
3. 配置VLAN与VLANIF
4. 在端口配置管理VLAN为Untagged,业务存储VLAN为tagged
5. 配置上行到汇聚交换机的默认路由。
6. 配置telnet登录
7. FusionCompute上配置CNA主机上行链路端口绑定。
CX110配置脚本与说明

#1 配置堆叠特性
#1.1配置2X堆叠特性, 默认堆叠ID为2,Domain ID为10,优先级为150。
#进入一阶段生效模式,不用敲Commit,配置直接生效。
system-view immidiately
sysname CX110_2
stack
stack priority 150
stack member 2 domain 10
quit
# 将CX110_2的业务口40GE2/18/1和40GE2/18/2加入堆叠端口2/1
interface 40GE 2/18/1
port mode stack
shutdown
quit
interface 40GE 2/18/2
port mode stack
shutdown
quit
interface stack-port 2/1
port member-group interface 40GE 2/18/1
port member-group interface 40GE 2/18/2
quit
#1.2 配置3X堆叠特性,默认堆叠ID为3,Domain ID为10(必须与2X相同),优先级为100。
#进入一阶段生效模式,不用敲Commit,配置直接生效。
system-view immidiately
sysname CX110_3
stack
stack priority 100
stack member 3 domain 10
quit
# 将CX110_3的业务口40GE3/18/1和40GE3/18/2加入堆叠端口3/1
interface 40GE 3/18/1
port mode stack
shutdown
interface 40GE 3/18/2
port mode stack
shutdown
quit
interface stack-port 3/1
port member-group interface 40GE 3/18/1
port member-group interface 40GE 3/18/2
quit
#1.3打开2X和3X槽位互联的40GE 堆叠端口
interface 40GE 2/18/1
undo shutdown
quit
interface 40GE 2/18/2
undo shutdown
quit
interface 40GE 3/18/1
undo shutdown
quit
interface 40GE 3/18/2
undo shutdown
quit
#1.4在2X,3X执行下列操作,保存配置,重启系统,验证配置
Ctrl+z
save
y
reboot
#验证堆叠配置
display stack
----------------------------------------------------------------
MemberID Role MAC Priority Device Type
----------------------------------------------------------------
2 Master 0004-9f31-d922 150 CX110
3 Standby 0004-9f62-2f42 100 CX110
----------------------------------------------------------------
#堆叠配置完成后2X,3X逻辑上变成一台交换机,剩余配置在2X上完成即可。

#2配置上行链路聚合/端口绑定
#2X,3X分别上行4条链路,绑定后变成一条逻辑链路。
interface Eth-Trunk10
trunkport 10GE 2/17/1
trunkport 10GE 2/17/2
trunkport 10GE 2/17/3
trunkport 10GE 2/17/4
trunkport 10GE 3/17/1
trunkport 10GE 3/17/2
trunkport 10GE 3/17/3
trunkport 10GE 3/17/4
quit
# 配置链路聚合组的负荷分担模式为:源+目的IP地址
interface Eth-Trunk10
load-balance src-dst-ip
quit

#3 配置VLAN与VLANIF
#3.1创建管理VLAN 101,业务VLAN 600,601,606,存储VLAN 609。
vlan batch 101 600 to 601 606 609
interface Vlanif101
ip address 10.6.70.129 255.255.255.0
#如果在管理界面或命令行设置交换板管理IP(接口MEth0/0/0)与CNA的管理IP同网段,两者无法互通,也无法配置管理网段VLANIF。
#此时需要undo接口MEth0/0/0的管理IP,然后配置管理VLANIF,实现互通。
interface Vlanif600
ip address 10.6.0.252 255.255.255.0
quit
interface Vlanif601
ip address 10.6.1.252 255.255.255.0
quit
interface Vlanif606
ip address 10.6.6.252 255.255.255.0
quit
interface Vlanif609
ip address 10.6.9.252 255.255.255.0
quit

#4 在CX110端口上配置管理VLAN为untagged,业务与存储VLAN为tagged。
#在上行聚合链路配置允许所有VLAN通过。
interface Eth-Trunk10
port link-type hybrid
port hybrid pvid vlan 101
port hybrid tagged vlan 600 to 601 606 609
undo port hybrid vlan 1
port hybrid untagged vlan 101
quit
#Eth-Trunk也可以用下面的配置,一次性允许所有VLAN通过。
#port link-type trunk
#port trunk allow-pass vlan all
#quit
#在Slot1刀片的MZ110的port 0和2 接CX110的 GE2/1/1与GE 3/1/1,作为管理和业务链路,配置允许管理和业务VLAN通过。
interface GE2/1/1
port link-type hybrid
port hybrid pvid vlan 101
port hybrid tagged vlan 600 to 601 606
undo port hybrid vlan 1
port hybrid untagged vlan 101
interface GE3/1/1
port link-type hybrid
port hybrid pvid vlan 101
port hybrid tagged vlan 600 to 601 606
undo port hybrid vlan 1
port hybrid untagged vlan 101
#在Slot1的刀片上MZ110的port 1和3 接CX110的 GE2/1/2与GE 3/1/2,作为存储链路,配置允许存储VLAN通过。
interface GE2/1/2
port link-type hybrid
port hybrid pvid vlan 101
port hybrid tagged vlan 609
undo port hybrid vlan 1
port hybrid untagged vlan 101
interface GE3/1/2
port link-type hybrid
port hybrid pvid vlan 101
port hybrid tagged vlan 609
undo port hybrid vlan 1
port hybrid untagged vlan 101
#其他下行端口(连接刀片)的配置与上述配置相同。

#5 配置上行到汇聚交换机的默认路由。
ip route-static 0.0.0.0 0.0.0.0 10.6.70.254

#6 配置telnet登录
user-interface vty 0 4
user privilege level 3
authentication-mode aaa
protocol inbound all
quit
aaa
local-user root password  irreversible-cipher Huawei12#$
local-user root service-type telnet
local-user root level 5
quit
#保存配置
Ctrl+z
save
y
#7 在FusionCompute上配置CNA主机上行链路端口绑定。
参考FusionCompute产品文档:网络管理 > 分布式交换机管理 > 添加上行链路 章节。

根因
部件型号太多,内部结构复杂,组网方式较多,配置方式叫复杂,文档指导不够清楚。


解决方案
更多信息请参考:
1. E9000开局指导书
2. E9000 网络应用与配置指南
3. http://e.huawei.com/serverhelp
建议与总结

1. 建议在后续E9000版本对交换板各部件不同型号进行整合,尽量保持不同型号组合之间的配置一致性。
2. 建议E9000交换板配置文档写得更详细一些。

END