S9300 配置三层远程镜像抓不到包

发布时间:  2014-12-30 浏览次数:  130 下载次数:  0
问题描述
如以下截图所示,两台S9300之间是通过3层互通,在S9300-1上配置将客户端过来的报文三层远程镜像到服务器上,配置镜像后在服务器上抓不到镜像报文。

处理过程
一下附上相关配置:
S9300-1

#

observe-port 1 interface GigabitEthernet 1/0/1 destination-ip 192.168.2.254source-ip 192.168.1.100
#

interface GigabitEthernet1/0/0

port link-type access

port default vlan 10

port-mirroring to observe-port 1 inbound

#

interface GigabitEthernet1/0/1

port link-type trunk

port trunk allow-pass vlan 3

#



S9300-2

#

interface GigabitEthernet2/0/0

port link-type access

port default vlan 5

#

interface GigabitEthernet2/0/1

port link-type trunk

port trunk allow-pass vlan 3

1.检查后发现IP地址都可达。
2.在观察端口有镜像流量发出。
3.网络中也没有环路等会导致异常丢包的现象。
4.排查后发现是端口镜像的配置命令不完整,应该这样配置:
observe-port 1 interface GigabitEthernet 1/0/1 destination-ip 4.4.4.134 source-ip 2.2.2.138 vlan 3
将命令补全后问题解决。
根因
如果配置远程端口镜像,需在命令行中指定出方向vlan。

END