One switch use cable connect to another switch, ping function is unavailable

Publication Date:  2014-12-31 Views:  433 Downloads:  0
Issue Description
One switch use cable connect to another switch.
Switch A(G0/0/3) ---- Switch B(G0/1/1)
Configuration of switch A:
[oindcaslhwb6-GigabitEthernet0/0/3]di th                                       
#                                                                              
interface GigabitEthernet0/0/3                                                 
undo negotiation auto                                                                                  
port link-type access                                                         
port default vlan 117                                                         
#                                                                              
return                                                                                                                        
[oindcaslhwb6-Vlanif117]di th                                                  
#                                                                              
interface Vlanif117                                                            
arp detect-times 6                                                            
ip address x.x.7.1 255.255.255.0                                           
#                                                                              
return                               
Configuration of Switch B:
[oindcaslhwb7-GigabitEthernet0/1/1]di th                                       
#                                                                              
interface GigabitEthernet0/1/1                                                 
undo negotiation auto                                                           
port link-type trunk                                                         
port trunk allow-pass vlan 117                                                         
#                                                                              
return                                                                         
[oindcaslhwb7-Vlanif117]di th                                                  
#                                                                              
interface Vlanif117                                                            
ip address x.x.7.4 255.255.255.0                                           
#                                                                              
return                                                               
Switch A cannot ping Switch B:
<oindcaslhwb6>ping 10.241.7.4
  PING 10.241.7.4: 56  data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out

  --- 10.241.7.4 ping statistics ---
    5 packet(s) transmitted
    0 packet(s) received
    100.00% packet loss
Handling Process
1. Check port link status
Switch A:
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
GigabitEthernet0/0/3        up    up          0%     0%          0          0
Switch B:
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
GigabitEthernet0/1/1        up    up          0%     0%          0          0
2. Check vlanif status
Switch A:
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
Vlanif117                   up    up          --     --          0          0
Switch B:
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
Vlanif117                   up    up          --     --          0          0
3. Port and vlanif status are both up, that is to say physical link and protocol link are both normal.
We should check port configuration. Try change configuration of G0/1/1 in switch B the same with
G0/0/3 in switch A. Modify port link-type to access.
Switch A:
[oindcaslhwb7-GigabitEthernet0/1/1]di th                                      
#                                                                             
interface GigabitEthernet0/1/1                                                
undo negotiation auto                                                          
port link-type access                                                        
port default vlan 117                                                             
#   
Ping again:
<oindcaslhwb6>ping 10.241.7.4
  PING 10.241.7.4: 56  data bytes, press CTRL_C to break
    Reply from 10.241.7.4: bytes=56 Sequence=1 ttl=255 time=330 ms
    Reply from 10.241.7.4: bytes=56 Sequence=2 ttl=255 time=50 ms
    Reply from 10.241.7.4: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 10.241.7.4: bytes=56 Sequence=4 ttl=255 time=20 ms
    Reply from 10.241.7.4: bytes=56 Sequence=5 ttl=255 time=50 ms

  --- 10.241.7.4 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 20/100/330 ms
Ping function is normal now.
Root Cause
For access link-type of G0/0/3 in switch A, when packets send out from the port, they will be untagged. Switch B receive these packets, because of trunk link-type of G0/1/1 in switch B, packets will be added port's pvid. G0/1/1 port's pvid is vlan 1, but vlan 1 is not allowed to pass in G0/1/1, so the packets will be dropped in port G0/1/1.
Solution
Modify link-type to access, or add vlan 1 allow-pass vlan in G0/1/1 in Switch B.

END