交换机没有去使能STP,导致互联接口学习不到OSPF邻居,互联端口互ping不通

发布时间:  2015-01-22 浏览次数:  454 下载次数:  0
问题描述

 组网图如下:

  
组网概述:两台S5700交换机使用两条端口互联,互联端口采用access端口类型,在两台S5700交换机上分别配置两个vlanif接口地址,作为互联接口ip。

配置脚本:

lsw1配置:

vlan batch 2 to 3
#

interface Vlanif2
ip address 1.1.1.1 255.255.255.0
#
interface Vlanif3
ip address 2.2.2.1 255.255.255.0
#

interface GigabitEthernet0/0/1
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 3

ospf 1
area 0.0.0.0
  network 1.1.1.0 0.0.0.255
  network 2.2.2.0 0.0.0.255

lsw2配置:

vlan batch 2 to 3
#

interface Vlanif2
ip address 1.1.1.2 255.255.255.0
#
interface Vlanif3
ip address 2.2.2.2 255.255.255.0
#

interface GigabitEthernet0/0/1
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 3

ospf 1
area 0.0.0.0
  network 1.1.1.0 0.0.0.255
  network 2.2.2.0 0.0.0.255

故障现象:配置完成后,使用display OSPF peer查看邻居状态,发现只有一个接口可以学习到邻居,另一个接口互联ip不能ping通。

处理过程

1、检查OSPF配置:hello time 、area id、验证、版本号、掩码长度、区域类型(是否配置特殊区域,如配置两端类型需一致)

2、换一条网线排除网线原因造成的链路不通。

3、检查stp配置,查看stp功能是否去使能。

根因

由于两台S5700启用了stp功能,导致物理环路拓补(实际的逻辑拓补不存在环路)的其中一个端口被阻塞掉出于不转发状态。导致互联端口不能互通。

OSPF收不到对方发送过来的hello报文,学习不到邻居。

解决方案

1、使用stp disable将S5700的stp功能去使能。

2、S5700默认启用MSTP,如果不希望关闭stp功能可以通过配置MSTP对不同的vlan加入到不同的MSTP实例。

配置参考如下:

stp enable
stp mode mstp
stp instance 1 root primary
stp instance 2 root secondary
stp bpdu-protection
#
stp region-configuration
region-name RG1
instance 1 vlan 2
instance 2 vlan 3

建议与总结

使用三层交换设备进行OSPF组网时,需要注意交换设备的stp协议状态。

根据现网情况如果需要使能stp功能,需要将存在环路的端口划分到不同的MSTP实例当中,防止stp阻塞端口引起的OSPF学习不正常。

 

END