FAQ-WLAN网络直接转发模式下为何AP的业务vlan不要配置为vlan1

发布时间:  2015-02-12 浏览次数:  130 下载次数:  0
问题描述

无线业务在直接转发模式下,业务vlan1下的STA会获取到AP的管理vlan中的ip地址

 

组网拓扑如下:

 

ac 配置如下:

 

vlan batch 100
#
dhcp enable
#
interface Vlanif1
ip address 192.168.1.1 255.255.255.0
dhcp select interface
#
interface Vlanif100
ip address 192.168.100.1 255.255.255.0
dhcp select interface
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface Wlan-Ess0
#
wlan
wlan ac source interface vlanif100
ap id 0 type-id 19 mac 00e0-fc28-1870 sn 2102354483104218F96F
wmm-profile name wp id 0
traffic-profile name tp id 0
security-profile name sp id 0
service-set name ss id 0
  wlan-ess 0
  ssid test
  traffic-profile id 0
  security-profile id 0
radio-profile name rp id 0
  wmm-profile id 0
ap 0 radio 0
  radio-profile id 0
  service-set id 0 wlan 1

交换机配置如下:

interface Ethernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094

interface Ethernet0/0/1
port link-type trunk
port trunk pvid  vlan 100
port trunk allow-pass vlan 2 to 4094

 

查看终端和ap信息

[AC6605]display  ap  all
  All AP information(Normal-1,UnNormal-0):
  ------------------------------------------------------------------------------
  AP    AP                    AP              Profile   AP              AP
    /Region
  ID    Type                  MAC             ID        State           Sysname
  ------------------------------------------------------------------------------
  0     AP6010DN-AGN          00e0-fc28-1870    0/0     normal          ap-0
  ------------------------------------------------------------------------------
  Total number: 1
[AC6605]dis
[AC6605]display   ac
[AC6605]display   access-user
------------------------------------------------------------------------------
UserID Username                       IP address                   MAC 
------------------------------------------------------------------------------
17     548998872b91                   192.168.100.253           5489-9887-2b91
------------------------------------------------------------------------------
Total 1,1 printed

 

可以确认终端获取的ip地址为vlan100 网段的

对接入层交换机接口抓包分析

 

终端关联时发送的dhcp discover 报文没有打vlan tag 标记

 

ap的管理vlan只在有线环境有意义,对于ap来说只知道业务vlan,ap自身发送的数据为vlan1 ap的物理口pvid为vlan1透传所有vlan,ap上线发送的dhcp报文属于vlan1 出ap剥去vlan1的标签 交换机接口收到没有标签的数据包 打上pvid的标签(port trunk pvid  vlan 100 ) 使ap接入管理vlan100 正常上线。

无线业务vlan为1终端发送的数据出ap时由于与ap的物理口的pvid相同会剥去vlan tag,交换机接口接收到无标签的数据包就会打上了pvid的标签,所以终端获取到管理vlan100网段的ip地址。

 

 

 

解决方案

可以在ap上配置 lineate-port vlan tagged 1 使出ap的vlan1业务数据打上vlan1的标签

建议用隧道转发模式或者业务vlan1更改为其它vlan

END