FAQ-S2700配置灵活QinQ

发布时间:  2015-02-15 浏览次数:  279 下载次数:  0
问题描述
S2700配置灵活QinQ。
解决方案
  • 盒式交换机配置灵活QinQ

# 创建外层VLAN 2、VLAN 3和需要单层透传的VLAN 1000。

 

<HUAWEI> system-view
[HUAWEI] vlan batch 2 3 1000

# 配置下行接口GE0/0/1。

[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid   
[HUAWEI-GigabitEthernet0/0/1] qinq vlan-translation enable   //盒式设备,必须先使能VLAN转换功能
[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3   //接口以Untagged方式加入叠加后的VLAN 2和VLAN 3
[HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 1000   //接口透传单层VLAN 1000
[HUAWEI-GigabitEthernet0/0/1] port vlan-stacking vlan 100 to 200 stack-vlan 2   //对内层VLAN 100~200的报文添加上VLAN ID为2的外层Tag
[HUAWEI-GigabitEthernet0/0/1] port vlan-stacking vlan 300 to 400 stack-vlan 3   //对内层VLAN 300~400的报文添加上VLAN ID为3的外层Tag
[HUAWEI-GigabitEthernet0/0/1] port vlan-mapping vlan 1000 map-vlan 1000   //盒式5700EI、3700EI和3700SI对单层透传的VLAN,需要配置自身映射到自身的VLAN Mapping,其他形态不需要配置
[HUAWEI-GigabitEthernet0/0/1] quit

# 配置上行接口GE0/0/5透传叠加后的外层VLAN和需要单层透传的VLAN。

[HUAWEI] interface gigabitethernet0/0/5 
[HUAWEI-GigabitEthernet0/0/5] port link-type trunk
[HUAWEI-GigabitEthernet0/0/5] port trunk allow-pass vlan 2 3 1000
  • 框式交换机配置灵活QinQ

# 创建外层VLAN 2、VLAN 3和需要单层透传的VLAN 1000。

<HUAWEI> system-view
[HUAWEI] vlan batch 2 3 1000

# 配置下行接口GE1/0/1。

[HUAWEI] interface gigabitethernet1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid 
[HUAWEI-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3   //接口以Untagged方式加入叠加后的VLAN 2和VLAN 3
[HUAWEI-GigabitEthernet1/0/1] port hybrid tagged vlan 1000   //接口透传单层VLAN 1000
[HUAWEI-GigabitEthernet1/0/1] port vlan-stacking vlan 100 to 200 stack-vlan 2   //对内层VLAN 100~200的报文添加上VLAN ID为2的外层Tag
[HUAWEI-GigabitEthernet1/0/1] port vlan-stacking vlan 300 to 400 stack-vlan 3   //对内层VLAN 300~400的报文添加上VLAN ID为3的外层Tag
[HUAWEI-GigabitEthernet1/0/1] port vlan-mapping vlan 1000 map-vlan 1000   //S7700的ES0D0G24SA00和ES0D0G24CA00单板、S9700的EH1D2G24SSA0和EH1D2S24CSA0单板对单层透传的VLAN,需要配置自身映射到自身的VLAN Mapping,其他单板不需要配置
[HUAWEI-GigabitEthernet1/0/1] quit

# 配置上行接口GE2/0/1透传叠加后的外层VLAN和需要单层透传的VLAN。

[HUAWEI] interface gigabitethernet2/0/1 
[HUAWEI-GigabitEthernet2/0/1] port link-type trunk
[HUAWEI-GigabitEthernet2/0/1] port trunk allow-pass vlan 2 3 1000

END