FAQ-S5700基于IP地址划分VLAN

发布时间:  2015-02-15 浏览次数:  400 下载次数:  0
问题描述
S5700基于IP地址划分VLAN。
解决方案



# 在Switch上创建VLAN100、VLAN200和VLAN300。

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 100 200 300

# 在Switch上配置VLAN100与IP地址192.168.1.2/24关联。

[Switch] vlan 100
[Switch-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24
[Switch-vlan100] quit

# 在Switch上配置VLAN200与IP地址192.168.2.2/24关联。

[Switch] vlan 200
[Switch-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24
[Switch-vlan200] quit

# 在Switch上配置VLAN300与IP地址192.168.3.2/24关联。

[Switch] vlan 300
[Switch-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24
[Switch-vlan300] quit

# 在Switch上配置接口GE0/0/5、GE0/0/6、GE0/0/7为Hybrid类型,分别以untagged方式加入VLAN100、VLAN200和VLAN300。并使能基于IP子网划分VLAN功能。

[Switch] interface gigabitethernet 0/0/5
[Switch-GigabitEthernet0/0/5] port link-type hybrid
[Switch-GigabitEthernet0/0/5] port hybrid untagged vlan 100
[Switch-GigabitEthernet0/0/5] ip-subnet-vlan enable
[Switch-GigabitEthernet0/0/5] quit
[Switch] interface gigabitethernet 0/0/6
[Switch-GigabitEthernet0/0/6] port link-type hybrid
[Switch-GigabitEthernet0/0/6] port hybrid untagged vlan 200
[Switch-GigabitEthernet0/0/6] ip-subnet-vlan enable
[Switch-GigabitEthernet0/0/6] quit
[Switch] interface gigabitethernet 0/0/7
[Switch-GigabitEthernet0/0/7] port link-type hybrid
[Switch-GigabitEthernet0/0/7] port hybrid untagged vlan 300
[Switch-GigabitEthernet0/0/7] ip-subnet-vlan enable
[Switch-GigabitEthernet0/0/7] quit

END