S2700 QINQ配置

发布时间:  2015-02-11 浏览次数:  289 下载次数:  0
问题描述

S2700 怎么配置qinq

 

解决方案

配置基于接口的QinQ示例

组网需求

图1所示,网络中有两个大企业,企业1有两个办公地,企业2有三个办公地,这两个企业的各办公地的企业网都分别和运营商网络中的SwitchG或SwitchF相连。企业1的网络中使用VLAN1000~VLAN1500,企业2的网络中使用VLAN2000~VLAN3000。要求企业内部各办公地相同VLAN内用户可以通过运营商的网络互相通信,但两个企业之间互相隔离。

图1 配置基于接口的QinQ组网图

配置思路

采用如下的思路配置QinQ:

  1. SwitchF上创建VLAN10和VLAN20,在SwitchG上创建VLAN20。

  2. SwitchF上配置接口Eth0/0/1、Eth0/0/2、Eth0/0/3的类型为QinQ。

  3. SwitchG上配置接口Eth0/0/1、Eth0/0/2的类型为QinQ。

  4. 配置SwitchF的接口Eth0/0/4和SwitchG的接口Eth0/0/3以Tag方式加入VLAN20。

数据准备

为完成此配置例,需准备如下的数据:

  • 在运营商网络中企业1被划分在VLAN10中。

  • 在运营商网络中企业2被划分在VLAN20中。

操作步骤

  1. 创建VLAN

    # 在SwitchF上创建VLAN10和VLAN20。

    <Quidway> system-view
    [Quidway] sysname SwitchF
    [SwitchF] vlan batch 10 20

    # 在SwitchG上创建VLAN20。

    <Quidway> system-view
    [Quidway] sysname SwitchG
    [SwitchG] vlan 20

  2. 配置接口类型为QinQ

    # 在SwitchF上配置接口Eth0/0/1、Eth0/0/2、Eth0/0/3类型为QinQ,Eth0/0/1、Eth0/0/3的外层Tag为VLAN10,Eth0/0/2的外层Tag为VLAN20。

    [SwitchF] interface ethernet 0/0/1
    [SwitchF-Ethernet0/0/1] port link-type dot1q-tunnel
    [SwitchF-Ethernet0/0/1] port default vlan 10
    [SwitchF-Ethernet0/0/1] quit
    [SwitchF] interface ethernet 0/0/2
    [SwitchF-Ethernet0/0/2] port link-type dot1q-tunnel
    [SwitchF-Ethernet0/0/2] port default vlan 20
    [SwitchF-Ethernet0/0/2] quit
    [SwitchF] interface ethernet 0/0/3
    [SwitchF-Ethernet0/0/3] port link-type dot1q-tunnel
    [SwitchF-Ethernet0/0/3] port default vlan 10
    [SwitchF-Ethernet0/0/3] quit

    # 在SwitchG上配置接口Eth0/0/1、Eth0/0/2类型为QinQ接口,Eth0/0/1、Eth0/0/2的外层Tag为VLAN20。

    [SwitchG] interface ethernet 0/0/1
    [SwitchG-Ethernet0/0/1] port link-type dot1q-tunnel
    [SwitchG-Ethernet0/0/1] port default vlan 20
    [SwitchG-Ethernet0/0/1] quit
    [SwitchG] interface ethernet 0/0/2
    [SwitchG-Ethernet0/0/2] port link-type dot1q-tunnel
    [SwitchG-Ethernet0/0/2] port default vlan 20
    [SwitchG-Ethernet0/0/2] quit

  3. 配置其它接口

    # 在SwitchF上配置接口Eth0/0/4加入VLAN20。

    [SwitchF] interface ethernet 0/0/4
    [SwitchF-Ethernet0/0/4] port link-type trunk
    [SwitchF-Ethernet0/0/4] port trunk allow-pass vlan 20
    [SwitchF-Ethernet0/0/4] quit
    

    # 在SwitchG上配置接口Eth0/0/3加入VLAN20。

    [SwitchG] interface ethernet 0/0/3
    [SwitchG-Ethernet0/0/3] port link-type trunk
    [SwitchG-Ethernet0/0/3] port trunk allow-pass vlan 20
    [SwitchG-Ethernet0/0/3] quit

  4. 验证配置结果

    从企业1任意办公地内任意VLAN的一台主机ping企业1其它工作地同一VLAN内的主机,如果可以ping通则表示企业1内部可以互相通信。

    从企业2任意办公地内任意VLAN的一台主机ping企业2其它工作地同一VLAN内的主机,如果可以ping通则表示企业2内部可以互相通信。

    从企业1任意办公地内的任意一台主机ping企业2内的主机,如果不能ping通则表示企业1和企业2是互相隔离的。

END