FAQ-S5700哪些支持GRE配置,怎么配置GRE

发布时间:  2015-02-15 浏览次数:  240 下载次数:  0
问题描述

S5700系列的交换机哪些支持配置GRE,具体怎么配置?

 

解决方案

仅S5700HI、S5710EI和S5710HI设备支持GRE特性。

配置GRE over IPv4(静态路由)

图1SwitchA、SwitchB、SwitchC使用OSPF协议路由可达。现需要在SwitchA和SwitchC之间建立直连链路,可以部署GRE隧道,通过静态路由指定到达对端的报文通过Tunnel接口转发,PC1和PC2可以互相通信。

其中PC1和PC2上分别指定SwitchA、SwitchC为自己的缺省网关。

配置GRE使用静态路由组网图


配置GRE使用静态路由的思路如下:

  1. 所有设备之间运行路由协议实现互通,本示例使用OSPF路由。

  2. SwitchA和SwitchC上创建Tunnel接口,配置GRE隧道,指定Tunnel的源地址和目的地址,使报文封装后可以通过OSPF路由转发。注意Tunnel的源地址是发出报文的物理接口IP地址,目的地址是接收报文的物理接口IP地址。

  3. 为使PC1和PC2之间的流量通过GRE隧道传输,SwitchA和SwitchC上配置静态路由,以对端PC所在网段为目的地址,出接口为本端配置的Tunnel接口。

 

配置步骤:

  1. 配置各物理接口的IP地址

    # 配置SwitchA。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type access
    [SwitchA-GigabitEthernet0/0/1] port default vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 20.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.1.2 24
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 20
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type access
    [SwitchB-GigabitEthernet0/0/1] port default vlan 10
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type access
    [SwitchB-GigabitEthernet0/0/2] port default vlan 20
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 20.1.1.2 24
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ip address 30.1.1.1 24
    [SwitchB-Vlanif20] quit

    # 配置SwitchC。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 10 20
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type access
    [SwitchC-GigabitEthernet0/0/1] port default vlan 10
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface gigabitethernet 0/0/2
    [SwitchC-GigabitEthernet0/0/2] port link-type access
    [SwitchC-GigabitEthernet0/0/2] port default vlan 20
    [SwitchC-GigabitEthernet0/0/2] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] ip address 30.1.1.2 24
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] ip address 10.2.1.2 24
    [SwitchC-Vlanif20] quit

  2. 配置设备间使用OSPF路由

    # 配置SwitchA。

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchC。

    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # 配置完成后,在SwitchA和SwitchC上执行display ip routing-table命令,可以看到他们能够学到去往对端接口网段地址的OSPF路由。

    # 以SwitchA的显示为例。

    [SwitchA] display ip routing-table protocol ospf
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Public routing table : OSPF
             Destinations : 1        Routes : 1
    
    OSPF routing table status : <Active>
             Destinations : 1        Routes : 1
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           30.1.1.0/24  OSPF    10   2           D   20.1.1.2        Vlanif10
    
    OSPF routing table status : <Inactive>
             Destinations : 0        Routes : 0
    

  3. 配置Tunnel接口

    # 配置SwitchA。

    [SwitchA] interface tunnel 1
    [SwitchA-Tunnel1] tunnel-protocol gre
    [SwitchA-Tunnel1] ip address 40.1.1.1 255.255.255.0
    [SwitchA-Tunnel1] source 20.1.1.1
    [SwitchA-Tunnel1] destination 30.1.1.2
    [SwitchA-Tunnel1] quit

    # 配置SwitchC。

    [SwitchC] interface tunnel 1
    [SwitchC-Tunnel1] tunnel-protocol gre
    [SwitchC-Tunnel1] ip address 40.1.1.2 255.255.255.0
    [SwitchC-Tunnel1] source 30.1.1.2
    [SwitchC-Tunnel1] destination 20.1.1.1
    [SwitchC-Tunnel1] quit

    # 配置完成后,Tunnel接口状态变为Up,Tunnel接口之间可以Ping通,直连隧道建立。

    # 以SwitchA的显示为例:

    [SwitchA] ping -a 40.1.1.1 40.1.1.2
      PING 40.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 40.1.1.2: bytes=56 Sequence=1 ttl=255 time=1 ms
        Reply from 40.1.1.2: bytes=56 Sequence=2 ttl=255 time=1 ms
        Reply from 40.1.1.2: bytes=56 Sequence=3 ttl=255 time=1 ms
        Reply from 40.1.1.2: bytes=56 Sequence=4 ttl=255 time=1 ms
        Reply from 40.1.1.2: bytes=56 Sequence=5 ttl=255 time=1 ms
    
      --- 40.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/1/1 ms
    

  4. 配置静态路由

    # 配置SwitchA。

    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 tunnel 1

    # 配置SwitchC。

    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 tunnel 1

    # 配置完成后,在SwitchA和SwitchC上执行display ip routing-table命令,可以看到去往对端用户侧网段的静态路由出接口为Tunnel接口。

    # 以SwitchA的显示为例。

    [SwitchA] display ip routing-table 10.2.1.0
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 1
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.2.1.0/24  Static  60   0           D   40.1.1.2        Tunnel1
    

    PC1和PC2可以相互Ping通。

END