FAQ-S5700交换机如何配置qinq功能

发布时间:  2016-12-20 浏览次数:  680 下载次数:  8
问题描述
S5700交换机如何配置qinq功能?
解决方案

配置基本QinQ示例

组网需求
如图1所示,网络中有两个企业,企业1有两个分支,企业2有两个分支。这两个企业的各办公地的企业网都分别和运营商网络中的SwitchA和SwitchB相连,且公网中存在其它厂商设备,其外层VLAN Tag的TPID值为0x9100。

现需要实现:
企业1和企业2独立划分VLAN,两者互不影响。
各企业两分支之间流量通过公网透明传输,相同业务之间互通,不同业务之间互相隔离。
可通过配置QinQ来实现以上需求。利用公网提供的VLAN100使企业1互通,利用公网提供的VLAN200使企业2互通,不同企业之间互相隔离。并通过在连接其它厂商设备的接口上配置修改QinQ外层VLAN Tag的TPID值,来实现与其它厂商设备的互通。

图1 配置基本QinQ示例组网图


 

配置思路
采用如下的思路配置QinQ:

在SwitchA和SwitchB上均创建VLAN100和VLAN200,配置连接业务的接口为QinQ类型,并分别加入VLAN。实现不同业务添加不同的外层VLAN Tag。

配置SwitchA和SwitchB上连接公网的接口加入相应VLAN,实现允许VLAN100和200的报文通过。

在SwitchA和SwitchB连接公网的接口上配置外层VLAN tag的TPID值,实现与其它厂商设备的互通。

操作步骤
创建VLAN

# 在SwitchA上创建VLAN100和VLAN200

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100 200
# 在SwitchB上创建VLAN100和VLAN200

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 100 200

配置接口类型为QinQ

# 在SwitchA上配置接口GE0/0/1、GE0/0/2的类型为QinQ,GE0/0/1的外层tag为VLAN100,GE0/0/2的外层tag为VLAN200。

[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/1] port default vlan 100
[SwitchA-GigabitEthernet0/0/1] quit
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/2] port default vlan 200
[SwitchA-GigabitEthernet0/0/2] quit
# 在SwitchB上配置接口GE0/0/1、GE0/0/2的类型为QinQ,GE0/0/1的外层tag为VLAN100,GE0/0/2的外层tag为VLAN200。配置过程与SwitchA相同,不再赘述。

配置Switch连接公网侧的接口

# 在SwitchA上配置接口GE0/0/3加入VLAN100和VLAN200。

[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200
[SwitchA-GigabitEthernet0/0/3] quit# 在SwitchB上配置接口GE0/0/3加入VLAN100和VLAN200。配置过程与SwitchA相同,不再赘述。

配置外层VLAN tag的TPID值

# 在SwitchA上配置外层VLAN tag的TPID值为0x9100。

[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] qinq protocol 9100
# 在SwitchB上配置外层VLAN tag的TPID值为0x9100。

[SwitchB] interface gigabitethernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] qinq protocol 9100

验证配置结果

从企业1一处分支内任意VLAN的一台PC ping企业1另外一处分支同一VLAN内的PC,如果可以ping通则表示企业1内部可以互相通信。

从企业2一处分支内任意VLAN的一台PC ping企业2另外一处分支同一VLAN内的PC,如果可以ping通则表示企业2内部可以互相通信。

从企业1一处分支内任意VLAN的一台PC ping企业2任意一处分支同一VLAN内的PC,如果不能ping通则表示企业1和企业2之间相互隔离。


配置灵活QinQ示例

组网需求
如图1所示,PC上网用户和VoIP用户通过SwitchA和SwitchB接入运营商网络,通过运营商的网络互相通信。

企业内部为PC分配的企业内部VLAN为100,为VoIP电话分配的内部电话为300。

要求PC上网用户和VoIP用户分别以VLAN2和VLAN3通过运营商网络。

图1 配置灵活QinQ组网图


 

配置思路
采用如下的思路配置灵活QinQ:

在SwitchA和SwitchB上创建相关VLAN。

在SwitchA和SwitchB上配置接口类型并加入VLAN。

在SwitchA和SwitchB的接口上配置灵活QinQ功能。

操作步骤
创建VLAN

# 在SwitchA上创建VLAN2、VLAN3,即叠加后的外层VLAN。

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 2 3# 在SwitchB上创建VLAN2、VLAN3,即叠加后的外层VLAN。

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 2 3
在接口上配置灵活QinQ

# 配置SwitchA的接口GE0/0/1。

[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type hybrid
[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchA-GigabitEthernet0/0/1] quit# 配置SwitchB的接口GE0/0/1。

[SwitchB] interface gigabitethernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type hybrid
[SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchB-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchB-GigabitEthernet0/0/1] quit
配置其它接口

# 在SwitchA上配置接口GE0/0/2加入VLAN2、VLAN3。

[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchA-GigabitEthernet0/0/2] quit# 在SwitchB上配置接口GE0/0/2加入VLAN2、VLAN3。

[SwitchB] interface gigabitethernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type trunk
[SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchB-GigabitEthernet0/0/2] quit

验证配置结果

如果SwitchA、SwitchB上配置正确,则:

PC上网用户可以通过运营商网络互相通信。

VoIP用户可以通过运营商网络互相通信。


 

END