FAQ-内置portal+本地认证配置案例

发布时间:  2016-02-03 浏览次数:  1083 下载次数:  0
问题描述
内置portal+本地认证配置案例。
解决方案

设备配置:

网络配置,VLANIF 88为管理VLAN为AP分配地址,VLANIF 100为业务VLAN为终端分配地址。

[AC6605]dhcp enable
[AC6605]vlan batch 88 100
[AC6605]interface Vlanif 88
[AC6605-Vlanif88]ip address 192.168.88.1 255.255.255.0
[AC6605-Vlanif88]dhcp select interface
[AC6605]interface Vlanif 100
[AC6605-Vlanif100]ip address 192.168.100.1 255.255.255.0
[AC6605-Vlanif100]dhcp select interface
[AC6605-Vlanif100]dhcp server dns-list 218.85.152.99

配置与上行设备通信接口地址,添加一条默认路由,指向USG防火墙

[AC6605]interface Vlanif 1
[AC6605-Vlanif1]ip address 192.168.31.100 255.255.255.0
[AC6605]ip route-static 0.0.0.0 0.0.0.0 192.168.31.1

配置AC与AP相连的端口。

[AC6605]interface GigabitEthernet0/0/11
[AC6605-GigabitEthernet0/0/11]port link-type trunk
[AC6605-GigabitEthernet0/0/11]port trunk pvid vlan 88
[AC6605-GigabitEthernet0/0/11]undo port trunk allow-pass vlan 1
[AC6605-GigabitEthernet0/0/11]port trunk allow-pass vlan 88 100

创建本地用户(登录时候用到)。

[AC6605]aaa
[AC6605-aaa]local-user huawei password cipher Admin@123
[AC6605-aaa]local-user huawei service-type web(增加本地用户web认证权限)

配置内置Portal的Server Portal服务器IP地址。推荐指向的IP地址使用LoopBack接口地址。利用LoopBack接口状态稳定的优点,可以避免因为接口故障导致用户无法打开的问题。

[AC6605]interface loopback 99
[AC6605-LoopBack99]ip address 192.168.99.1 255.255.255.0
[AC6605]portal local-server ip 192.168.99.1

配置内置Portal 的SSL策略和端口号(默认443已被AC WEB管理占用,不可用)。

[AC6605]portal local-server https ssl-policy default_policy port 2000
Info: Load web file successfully.

配置免认证规则。

[AC6605]portal free-rule 0 destination ip 218.85.152.99 mask 255.255.255.255

配置wlan-ess接口,在wlan-ess接口调用内置Portal与允许的认证域。

[AC6605]interface Wlan-Ess 1
[AC6605-Wlan-Ess1]port hybrid pvid vlan 100
[AC6605-Wlan-Ess1]port hybrid untagged vlan 100
[AC6605-Wlan-Ess1]portal local-server enable
[AC6605-Wlan-Ess1]permit-domain name default(调用default认证域,该域默认使用本地认证;如使用其他认证域,请确认调用了本地用户认证方法。)

配置AC的源接口,用于AC和AP之间建立隧道通信。

[AC6605]wlan
[AC6605-wlan-view]wlan ac source interface vlanif88

配置AP的认证方式为免认证。

[AC6605-wlan-view]ap-auth-mode no-auth

添加AP。

[AC6605-wlan-view]ap id 0 type-id 31 mac d4b1-10ac-0b00 sn 210235582910D6000354

创建名为“wmm1”的WMM模版,参数采用默认配置。

[AC6605-wlan-view]wmm-profile name wmm1 id 1

创建名为“radio1”的射频模版,绑定WMM模版“wmm1”。

[AC6605-wlan-view]radio-profile name radio1 id 1
[AC6605-wlan-radio-prof-radio1]wmm-profile id 1

创建名为“traffic1”的流量模版,参数采用默认配置。

[AC6605-wlan-view]traffic-profile name traffic1 id 1

创建名为“security1”的安全模版,认证方式为WEP认证,开放认证,不加密。

[AC6605-wlan-view]security-profile name security1 id 1

创建名为“service1”的服务集,并绑定流量模版和安全模版,WLAN-ESS接口。

[AC6605-wlan-view]service-set name service1 id 1
[AC6605-wlan-service-set-service1]wlan-ess 1
[AC6605-wlan-service-set-service1]ssid huawei-portal
[AC6605-wlan-service-set-service1]traffic-profile id 1
[AC6605-wlan-service-set-service1]security-profile id 1
[AC6605-wlan-service-set-service1]service-vlan 100

配置AP对应的VAP,下发WLAN服务

[AC6605-wlan-view]ap 0 radio 0
[AC6605-wlan-radio-0/0]radio-profile id 1
[AC6605-wlan-radio-0/0]service-set id 1 wlan 1

下发AP的WLAN配置

[AC6605-wlan-view]commit all

测试结果:

终端搜索SSID,并连接。





测试PING www.qq.com



打开IE,输入www.qq.com

自动跳转到认证页面



可点击右上角中文切换为中文认证页面



输入预先在AC上创建的用户进行登陆





登陆成功,测试登陆后是否可以正常访问互联网



END