CE12804双链路互联CE5800链路时断时续,无法通过冗余链路Telnet远程管理

发布时间:  2015-03-27 浏览次数:  220 下载次数:  1
问题描述
CE12804 PING CE5800的管理IP地址时时断时续,无法通过冗余链路远程Telnet管理CE5800。
告警信息

处理过程

1、检查全局配置信息

(1)   在全局下面检查配置,全局配置和Telnet管理配置正常。

设备连接信息描述:

SW1G1/0/1口和G1/0/2 分别对应与SW2G1/0/1口和G1/0/2相连。

SW1G1/0/1口和SW2G1/0/1口为access 口,允许vlan10通过

Sw1G1/0/2Sw2G1/0/2口为trunk口,允许vlan20通过

 

<sw1>dis cur

#

sysname sw1

#

vlan batch 10 20

#

interface Vlanif10

 ip address 10.10.10.2 255.255.255.0

#

interface Vlanif20

 ip address 20.20.20.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

user-interface vty 0 4

 authentication-mode aaa

#

return

 

[sw2]dis cur

#

sysname sw2

#

vlan batch 10 20

#

interface Vlanif10

 ip address 10.10.10.1 255.255.255.0

#

interface Vlanif20

 ip address 20.20.20.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

user-interface vty 0 4

 authentication-mode aaa

#

return

[sw2]

2)接口状态检查,检查后正常。

<sw1>dis ip int brief

Interface                         IP Address/Mask      Physical   Protocol 

Vlanif10                          10.10.10.2/24        up         up       

Vlanif20                          20.20.20.2/24        up         up       

<sw1>dis inte brief

Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors

GigabitEthernet1/0/1        up    up          0%     0%          0          0

GigabitEthernet1/0/2        up    up          0%     0%          0          0

 

 

 

[sw2]dis ip inte brief

 

Interface                         IP Address/Mask      Physical   Protocol 

Vlanif10                          10.10.10.1/24        up         up       

Vlanif20                          20.20.20.1/24        up         up       

 

[sw2]dis inte brief

Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors

GigabitEthernet1/0/1        up    up          0%     0%          0          0

GigabitEthernet1/0/2        up    up          0%     0%          0          0

端口状态正常

<sw1>ping 10.10.10.2

  PING 10.10.10.2: 56  data bytes, press CTRL_C to break

    Reply from 10.10.10.2: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from 10.10.10.2: bytes=56 Sequence=2 ttl=255 time=20 ms

    Reply from 10.10.10.2: bytes=56 Sequence=3 ttl=255 time=10 ms

    Reply from 10.10.10.2: bytes=56 Sequence=4 ttl=255 time=20 ms

<sw1>ping 10.10.10.1

  PING 10.10.10.1: 56  data bytes, press CTRL_C to break

    Reply from 10.10.10.1: bytes=56 Sequence=1 ttl=255 time=30 ms

    Reply from 10.10.10.1: bytes=56 Sequence=2 ttl=255 time=10 ms

    Reply from 10.10.10.1: bytes=56 Sequence=3 ttl=255 time=30 ms

    Reply from 10.10.10.1: bytes=56 Sequence=4 ttl=255 time=40 ms

    Reply from 10.10.10.1: bytes=56 Sequence=5 ttl=255 time=60 ms

 

<sw1>ping 20.20.20.1

  PING 20.20.20.1: 56  data bytes, press CTRL_C to break

    Request time out

    Request time out

    Request time out

    Request time out

    Request time out

 

  --- 20.20.20.1 ping statistics ---

    5 packet(s) transmitted

    0 packet(s) received

    100.00% packet loss

 

<sw1>ping 20.20.20.2

  PING 20.20.20.2: 56  data bytes, press CTRL_C to break

    Reply from 20.20.20.2: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from 20.20.20.2: bytes=56 Sequence=2 ttl=255 time=1 ms

    Reply from 20.20.20.2: bytes=56 Sequence=3 ttl=255 time=20 ms

    Reply from 20.20.20.2: bytes=56 Sequence=4 ttl=255 time=1 ms

    Reply from 20.20.20.2: bytes=56 Sequence=5 ttl=255 time=10 ms

 

Sw1无法通过vlan20 ping sw2,其它正常:

 

2、检查生成树配置

交换机默认开启stp功能,通过命令查看stp状态。

 

<sw1>dis stp brief

 MSTID  Port                        Role  STP State     Protection

   0    GigabitEthernet1/0/1        ROOT  FORWARDING      NONE

   0    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE

<sw2>dis stp brief

 MSTID  Port                        Role  STP State     Protection

   0    GigabitEthernet1/0/1        DESI  FORWARDING      NONE

   0    GigabitEthernet1/0/2        DESI  FORWARDING      NONE

 

生成树功能阻塞掉了数据。

 

根因

生成树配置问题。

解决方案

一:实际项目中,客户不允许配置mstp

 

因为两条链路通过的vlan不一样,天然无环,直接在端口下配置stp disable

 

 

二:部署mstp,配置两个不同的instance

 

sw1sw2上配置mstp,命令如下:

 

stp region-configuration


 

region-name 123


 

instance 1 vlan 10

 

instance 2 vlan 20

 

active region-configuration

建议与总结
交换机之间链路互访,软硬件配置正常情况下,交换机项目部分是由于生成树问题引起互联互通问题,通过分步骤测试,有多种解决方法,找到合适的解决方案即可。

END