s3300 v100r005 二层组播故障

发布时间:  2015-03-30 浏览次数:  285 下载次数:  0
问题描述

s3352-ei从上游网络被动接受组播流量,以广播方式转发 pc点播视频正常,但是开启igmp snooping 之后客户pc接受不到流量

拓扑图如下:

 

 

 

3352-ei主要配置 如下:


!Software Version V100R005C01SPC100
sysname Quidway
#
vlan batch  3464
#
igmp-snooping enable
#
vlan 3464
description IPTS-IN-1
igmp-snooping enable
igmp-snooping querier enable
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 3003 3451 3464 3996
igmp-snooping static-router-port vlan 3464
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 3464
#

查看组播组的成员接口

<Quidway>dis igmp-snooping port-info vlan 3464
-----------------------------------------------------------------------
                     (Source, Group)  Port                          Flag
-----------------------------------------------------------------------
VLAN 3464, 1 Entry(s)
                (*, 239.255.255.250)   GigabitEthernet0/0/2      -D-
                                                1 port(s)
-----------------------------------------------------------------------

查看二层组播转发表

<Quidway>dis l2-multicast forwarding-table vlan 3464
VLAN ID : 3464, Forwarding Mode : IP
--------------------------------------------------------------------
                     (Source, Group)    Interface             Out-Vlan
--------------------------------------------------------------------
                         Router-port    GigabitEthernet0/0/1     3464
                   (*, 232.0.110.36)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.37)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.38)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.39)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.40)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.41)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.42)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.43)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.44)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.45)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                   (*, 232.0.110.46)    Stream                   3464
                                        GigabitEthernet0/0/1     3464
                (*, 239.255.255.250)    GigabitEthernet0/0/2     3464
                                        GigabitEthernet0/0/1     3464
--------------------------------------------------------------------

在盒式V1R5版本中,二层组播新增支持SSM-Mapping和SSM-Policy功能,按照协议RFC4607规定,IP地址中232/8(232.0.0.0 - 232.255.255.255)网段被分配给特定源组播组地址(source-specific multicast),对于这个网段的组播地址,必须要指定源地址才可以生成组播转发表项。因此盒式设备软件版本为V1R5,当收到用户发送IGMPv2版本的232组播组范围内的Report报文时,是无法生成组播转发表项的,刚好客户的点播软件只支持IGMPV2。

 

解决方案

在vlan上配置igmp-snooping ssm-policy acl xxx:其中acl内为空配置,此时二层组播将所有组播组地址都认为是非SSM组地址,此时232的组播组也可以正常生成(*,G)转发表项。

END