s5700交换机上配置PIM-DM下面用户无法获取组播源某个组播组数据

发布时间:  2015-04-09 浏览次数:  250 下载次数:  0
问题描述

客户拓扑如下:

附上核心配置以及接入交换机配置:

核心交换机主要配置:
#
vlan batch 88 100 to 102 110 to 113
#
multicast routing-enable

#
interface Vlanif110
description For_Jiemaqi_1
ip address 192.168.110.254 255.255.255.0
pim dm

#
interface GigabitEthernet0/0/24
description To_Mult_To_S5700
port link-type access
port default vlan 100
#
interface NULL0
#
pim
#                                        
ip route-static 192.168.121.0 255.255.255.0 192.168.100.1
ip route-static 192.168.122.0 255.255.255.0 192.168.100.1
ip route-static 192.168.131.0 255.255.255.0 192.168.100.1
ip route-static 192.168.132.0 255.255.255.0 192.168.100.1
ip route-static 192.168.141.0 255.255.255.0 192.168.100.1

------------------------------------------------------

接入配置:


#
vlan batch 100 121 to 122 131 to 132 141
#
multicast routing-enable
#
multicast forwarding-table downstream-limit 1
#
igmp-snooping enable
#
vlan 1
description For_Mgt
vlan 100
description For_Mult_To_Video_Corel     
vlan 121
description To_NC_A
igmp-snooping enable
#
interface Vlanif1
description For_Mgt
ip address 192.168.88.1 255.255.255.0
#
interface Vlanif100
description For_Mult_To_Video_Corel
ip address 192.168.100.1 255.255.255.0
pim dm
#
interface Vlanif121
description To_NC_A
ip address 192.168.121.254 255.255.255.0
pim dm
igmp enable
dhcp select interface
#
interface Vlanif122
description To_NC_B
ip address 192.168.122.254 255.255.255.0
pim dm
igmp enable
dhcp select interface
                
#
interface GigabitEthernet0/0/48
description Mult_To_Video_Corel
port link-type access
port default vlan 100
#
interface NULL0
#
igmp
#
ip route-static 0.0.0.0 0.0.0.0 192.168.100.254

问题详细描述:

在接入交换机下面除了VLAN121的用户可以收到组播源发送的00006组播组数据,其他几个vlan都无法接收到该组组播数据。

 

告警信息

查看核心交换机相关组播信息:

<Video_Corel>dis multicast routing-table
Multicast routing table
Total 6 entries

00001. (192.168.110.78, 239.255.1.10)
       Uptime: 02:46:13
       Upstream Interface: Vlanif110

00002. (192.168.110.78, 239.255.1.11)
       Uptime: 02:42:04
       Upstream Interface: Vlanif110

00003. (192.168.110.78, 239.255.1.12)
       Uptime: 02:40:09
       Upstream Interface: Vlanif110

00004. (192.168.110.78, 239.255.1.13)
       Uptime: 02:35:18
       Upstream Interface: Vlanif110

00005. (192.168.110.78, 239.255.1.14)
       Uptime: 02:33:33
       Upstream Interface: Vlanif110

00006. (192.168.110.78, 239.255.1.15)
       Uptime: 02:32:28
       Upstream Interface: Vlanif110
       List of 1 downstream interface    
           1:  Vlanif100       //发现该组播组有出接口信息,指向与接入的互联网段VLAN100,从核心未发现异常。
<Video_Corel>dis multicast forwarding-table
Multicast Forwarding Table
Total 6 entries, 6 matched
(其他表项略)


00006. (192.168.110.78, 239.255.1.15)
     MID: 1, Flags: ACT
     Uptime: 02:32:34, Timeout in: 00:03:04
     Incoming interface: Vlanif110
     List of 1 outgoing interfaces:
       1: Vlanif100 
         Activetime: 00:01:26
     Matched 12921860 packets(17599573320 bytes), Wrong If 0 packets
     Forwarded 3667832 packets(4995587184 bytes)

从以上组播表项看来均无异常

 

再来看看接入的信息:

<Access_SW>dis mul ro
Multicast routing table
Total 7 entries

(其他表项略)

00006. (192.168.110.78, 239.255.1.15)
       Uptime: 00:03:18
       Upstream Interface: Vlanif100
       List of 2 downstream interfaces   
           1:  Vlanif121   //发现该组播组大的下行流量只有到VLAN121

<Access_SW>dis mul fo
Multicast Forwarding Table
Total 7 entries, 7 matched

(其他表项略)

00006. (192.168.110.78, 239.255.1.15)
     MID: 23, Flags: ACT
     Uptime: 00:03:28, Timeout in: 00:03:22
     Incoming interface: Vlanif100
     List of 1 outgoing interfaces:
       1: Vlanif121 
         Activetime: 00:03:03
     Matched 9801 packets(981344 bytes), Wrong If 0 packets
     Forwarded 9801 packets(981344 bytes)

处理过程

怀疑其他vlan上没有发送IGMP请求报文,于是抓包分析:

 

在其他vlan内测试,发现有请求该组播组的IGMP包发送。

咨询研发后发现在接入交换机存在一条配置:

multicast forwarding-table downstream-limit 1

这条命令限制了下行流的出接口数量,将出接口数量调大或者删除后问题解决。

 

 

根因

由于multicast forwarding-table downstream-limit 1命令导致下行流的出接口只有一个,所以只能在vlan121下接受该组播组数据。

解决方案
将multicast forwarding-table downstream-limit 后面跟的数字调大或者删除,默认为128.
建议与总结
除了组播问题除了常规的查看到组播源的单播路由表或者组播转发表现等信息,还需要注意配置中一些与之相关的命令是否会对业务造成影响。

END