Prompt Tone Indicating No Reply Played When an Agent Makes an Outgoing Call

Publication Date:  2015-04-17 Views:  144 Downloads:  0
Issue Description
An agent can answer incoming calls and place intra-office calls. However, when this agent makes an outgoing call, the prompt tone indicating no reply is played.
Handling Process
Step 1 Analyze the symptom.

The agent can make intra-office calls and answer incoming calls. However, this agent cannot place outgoing calls.

Step 2 Verify that user rights are configured correctly.

Step 3 Check the outgoing prefix and user attributes.

This agent does not have a long number. When the agent makes an outgoing call, the calling number changing rule is not enabled. It is confirmed that the all agents use the unified switchboard number when making outgoing calls.

Step 4 Change the outgoing prefix to enable the calling number changing rule when outgoing calls are placed.

config modify prefix dn 0 callcategory basic callattribute local  cldpredeal yes cliindex 1 officeselectcode 0

Step 5 Verify the outgoing prefix configuration.

This agent fails to make an outgoing call, and the prompt tone indicating no reply is played as well.

Step 6 Check the registration group.

Agents 6000 and 6001 have not subscribed to the registration group.

Step 7 Add agents 6000 and 6001 to this registration group.

For example, run the following two commands to add agents 6000 and 6001 to registration group 1.
config modify office user officeno 0 userdn 6000 reggroupid 1 number 2

Step 8 Verify the proceeding configuration.

The fault is rectified. This agent can make an outgoing call now.

----End
Root Cause
The possible causes are as follows:
  • The outgoing prefix and user right configurations are incorrect.
  • Data mapping is incorrect.
  • Faults occur in special services.
  • Other faults occur.

END