Failure to Hear the Two-Stage Dialing Tone When Making Outgoing Calls

Publication Date:  2015-04-17 Views:  101 Downloads:  0
Issue Description
Intra-office users cannot hear the two-stage dialing tone when making outgoing calls through trunks.
Handling Process
Step 1 Run the show office selectcode no <string> command to view the value of send2nddialtone. If the value is no, run the config modify office selectcode no <string> send2nddialtone yes command to change the value to yes.

Step 2 Run the show prefix dn <string> command to view the outgoing prefix. If the outgoing prefix is contained in other prefixes, add a prefix that is not contained in other prefixes.

Step 3 Run the show prefix dn <string> command to view the minimum number length of the outgoing prefix. If the minimum number length is not 0, run the config modify prefix dn <string> minlen0 command to change the minimum number length to 0.

Step 4 Check whether the SoftCo deletes the outgoing prefix based on the number change index. If the outgoing prefix is not deleted and the number change index is not created, run the config add predeal index 0 changetype delete changepos 0 changelen 1 command (assumes that the prefix length is 1) to create a number change index, and then run the config modify prefix dn <string> cldpredeal yes cldindex 0 command to delete the outgoing prefix.

Step 5 Run the display sip digitmap command to check for the digitmap matching the outgoing prefix on the IAD. If no digitmap matches the outgoing prefix, run the sip digitmap <string> command on the IAD to add a digitmap.

Step 6 If the fault persists, contact Huawei technical support engineers.

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Root Cause
1.  The value of send2nddialtone is no.

2.  The outgoing prefix is contained in other prefixes.

3.  The SoftCo fails to delete the outgoing prefix based on the number change index.

4.  The minimum number length of the outgoing prefix is not 0.

5.  The outgoing prefix is different from that defined in the digitmap on the IAD.

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