Failure for the Calling Party to Identify the RE-INVITE Message, Leading to Call Disconnection

Publication Date:  2015-07-15 Views:  207 Downloads:  0
Issue Description
Version: SoftCo V100R002C04SPC100

Networking: User A --> IP PBX --> SIP --> SoftCo9500 --> PRA --> CC08 --> User B

Symptom: User B can talk with user A. However, when user A calls user B and user B picks up the phone, the call is disconnected two seconds later.
Handling Process
Step 1 Use the UCMaint to collect logs of CCM, USAM, CM, RM, PRINT TIME, SIP, SIPTK, SIP APP, SIP signal, and PRI.

Step 2 Analyze the logs.

Log information shows that:
  • The INVITE message sent from the PBX to the SoftCo does not carry 100rel.
  • After receiving the ringback tone from the CC&08, the SoftCo transparently transmits the 183 message to the PBX.
  • After receiving the ACK message sent from the PBX, the SoftCo sends an INVITE message again to the PBX for re-negotiation.
  • Likewise, the PBX also sends an INVITE message again to the SoftCo for re-negotiation.
However, both the SoftCo and PBX cannot handle the resent INVITE messages. As a result, they two send the 491 message to each other, causing a failure.



There are three ways to rectify the fault:
  • Make the PBX carry 100rel in the INVITE message. Therefore, the SoftCo will not send RE-INVITE message.
  • Make the PBX not carry 100rel and enable the PBX to handle the RE-INVITE message sent by the SoftCo.
  • Communicate with the customer to disable all RBT services.
Step 3 Disable all RBT service on the CC08 site. The fault is rectified.

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Root Cause
1.  The conversion between narrowband and broadband of the SoftCo9500 is faulty

2.  The PBX or CC08 is faulty.
Suggestions
Analyzing SoftCo logs is critical for locating the fault because SIP messages will help determine whether the fault resides in the SoftCo or the peer device. This facilitates troubleshooting.

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