CTVMNR Failure

Publication Date:  2015-04-21 Views:  124 Downloads:  0
Issue Description



1. A user dials *91# on phone 9127 and hears "You have registered the call transfer to voice mailbox on no reply service."

2. A user places a call to phone 9127 on phone 9128. The user hears the announcement "The call is being transferred to the voice mailbox" at first. About 20s later, the user hears another announcement "The number you dialed cannot be answered."
Handling Process
Step 1 Verify that phone 9127 has enabled the CTVMNR service and parameters for interworking with the UMS are incorrectly configured.

Step 2 Reproduce the failure scenario.

Use phone 9128 to call phone 9127. The system plays the announcement "The call is being transferred to the voice mailbox" at first. About 20s later, the system plays another announcement "The number you dialed cannot be answered."
Capture and analyze SoftCo logs. The figure below shows detailed log information.



According to the proceeding figure, the formats of both calling and called parties are correct.

Step 3 Check UMS configurations.

Numbers 9128 and 9127 are configured as XXXX9128 and XXXX9127 on the UMS. Change the long numbers on the UMS to short numbers, therefore UMS phone numbers are consistent with those sent by the SoftCo.

Step 4 Retest the service scenario. The SoftCo failed to forward calls to the predefined voice mailbox.

On the switch, mirror the UMS port to capture packets. The SoftCo sends network packets to the UMS server; however, the UMS server does not respond.
The following figure shows the capture results.



Step 5 Run the following commands on the UMS to check license details:

[root@ums ~]# ps -ef|grep freeswitch 
root     17439 14964  0 11:50 pts/1    00:00:00 grep freeswitch //No UMS processes and continue the operation
[root@ums ~]# /usr/local/freeswitch/bin/freeswitch
Error: stacksize 4194303 is too large: run ulimit -s 240 or run /usr/local/freeswitch/bin/freeswitch -waste.
auto-adjusting stack size for optimal performance....
2013-03-06 11:51:09.757819 [INFO] switch_event.c:579 Activate Eventing Engine.
2013-03-06 11:51:09.758783 [DEBUG] switch_event.c:567 Create event dispatch thread 0
2013-03-06 11:51:10.026250 [INFO] switch_nat.c:393 Scanning for NAT
2013-03-06 11:51:10.026384 [DEBUG] switch_nat.c:152 Checking for PMP 1/5
2013-03-06 11:51:10.275591 [DEBUG] switch_nat.c:152 Checking for PMP 2/5
2013-03-06 11:51:10.276590 [DEBUG] switch_nat.c:152 Checking for PMP 3/5
2013-03-06 11:51:10.777474 [DEBUG] switch_nat.c:152 Checking for PMP 4/5
2013-03-06 11:51:11.776224 [DEBUG] switch_nat.c:152 Checking for PMP 5/5
2013-03-06 11:51:11.777226 [ERR] switch_nat.c:183 Error checking for PMP [general error]
2013-03-06 11:51:11.777242 [DEBUG] switch_nat.c:398 Checking for UPnP
2013-03-06 11:51:23.776457 [INFO] switch_nat.c:412 No PMP or UPnP NAT devices detected!
2013-03-06 11:51:23.779357 [ERR] switch_core.c:1812 lice_session_number ========== ! 0
2013-03-06 11:51:23.779715 [INFO] switch_core_sqldb.c:1279 Opening DB
2013-03-06 11:51:23.801435 [NOTICE] switch_scheduler.c:166 Starting task thread
2013-03-06 11:51:23.816511 [CONSOLE] switch_core.c:1890  Fatail Error :  Licene check error 
Cannot Initialize [Success]

Step 6 Conclude the failure reason.

The UMS fails to verify licenses.

Step 7 Re-upload the license file.

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Root Cause
1.  The called party does not enable the call transfer to voice mailbox on no reply (CTVMNR) service, or parameters for interworking with the UMS are incorrectly configured.

2.  The calling formats configured in the SoftCo are incorrect.

3.  UMS configurations, such as PBX IP address, UMS server address, and service number are not configured correctly.

4.  The communication between the SoftCo and the UMS is abnormal, leading to failure to forward calls to the UMS server.

5.  The UMS does not respond to calls sent by the SoftCo.
Suggestions
  • Number formats configured on the UMS must be consistent with those sent by the PBX.
  • If the UMS version is V100R001C01, users can run the umsstatus command on the UMS to check the UMS status. If any license faults occur, the system will display related error messages.

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