FXO Port Cannot Be Released Due to Incorrect Busy Tone Detection Parameter Setting

Publication Date:  2015-07-24 Views:  165 Downloads:  0
Issue Description
The U1930 V100R001C01SPC900 is connected to the PSTN through the AT0 trunk (FXO port). When an outer-office mobile phone user hangs up, the line cannot be automatically released, and is suspended in busy state. Finally, all AT0 lines are suspended, and the incoming and outgoing call services are interrupted.
Handling Process
Step 1 Make an outgoing call through the AT0 trunk (FXO port) by using an intra-office extension phone to call an outer-office mobile phone. Answer the call on the mobile phone, and verify that the call is connected properly.

Step 2 Run the show board slot x command to find the FXO port through which the call is made, where x indicates the slot ID of the OSU board.

In the following example, the call is made through FXO port 0.



Step 3 End the call on the mobile phone, but do not hang up the intra-office extension phone. The intra-office extension phone user hears the busy tone.

Step 4 Run the config start monitor osu tone slot 3 port 0 command. The U1900 starts to detect busy tone parameters on the specified line in the background. (In the preceding command, 3 and 0 are the slot ID of the OSU board and FXO port ID respectively.)

Step 5 Wait for about 30s, and run the config stop monitor osu tone command to stop busy tone parameter detection. The system immediately returns the busy tone parameters that are detected.

The following figure shows the busy tone parameters that are detected.



According the preceding figure, the busy tone parameters detected on the line are as follows:
 On-time: [167, 213] ms
 Off-time: [175, 225] ms
 Frequency: [394, 446] Hz

Step 6 Run the show tone detect parameter command to view the busy tone detection parameters configured on the U1900.



According to the preceding figure, the busy tone detection parameters are configured as follows:
 On-time: [300, 400] ms
 Off-time: [300, 400] ms
 Frequency: [425, 475] Hz
The busy tone detection parameters configured on the U1900 are different from actual busy tone parameters.

Step 7 Run the following command to configure the busy tone detection parameters to the same as the actual values:

config tone detect parameter tonetype busy1 frequency1min 394 frequency1max 446 ontime1min 167 ontime1max 213 offtime1min 175 offtime1max 225

Step 8 Test again. When the call is ended on the outer-office mobile phone, the U1900 immediately releases the call. The FXO port enters the idle state. The fault is rectified.

Step 9 Run the save command to save the setting.

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Root Cause
The basic on-hook principle for the AT0 trunk (FXO port) is as follows: For a call made through the AT0 trunk (FXO port), when the outer-office user hangs up, the carrier sends the busy tone to the line. The U1900 releases the line only when the busy tone is detected. However, analog lines do not have a unified standard. Different countries (even different carriers in a country) use different busy tone parameters. For most AT0 trunk projects, onsite detection is required, and busy tone detection parameters must be modified onsite.
Suggestions
The default signal tone standard used by the system is China standard. When deploying the device in other countries or regions, perform busy tone adaption.

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