CMS启动后服务无法正常访问

发布时间:  2015-04-25 浏览次数:  259 下载次数:  0
问题描述
CMS服务启动后,无法通过浏览器访问到CMS。
处理过程
1. 将CMS服务器的IP地址加入到Web配置台。

a. 以系统管理员登录Web配置台。
b. 选择“Web配置台 > 系统配置 > WAS”,单击“新增”。
c. 添加CMS服务器的IP地址。

2. 检查ICDCOMM启动状态。

a. 以系统管理员登录Web配置台。
b. 查看Tomcat启动日志。
如果日志显示加粗信息,表示ICDCOMM启动失败:

2013-09-30 03:32:17 [Common] WAS Initializing......
2013-09-30 03:32:17 [Common] Initializing config file......
2013-09-30 03:32:18 [Common] Initializing config file......OK!
2013-09-30 03:32:18 [Common] Initializing data source(ptdb)......
2013-09-30 03:32:18 [Common] Initializing data source(ptdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(wfmdb)......
2013-09-30 03:32:18 [Common] Initializing data source(wfmdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(sysmondb)......
2013-09-30 03:32:18 [Common] Initializing data source(sysmondb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(configdb)......
2013-09-30 03:32:18 [Common] Initializing data source(configdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(gmdb)......
2013-09-30 03:32:18 [Common] Initializing data source(gmdb)......Skipped!
2013-09-30 03:32:18 [Common] Connecting NIRC......
2013-09-30 03:32:18 [Common] Connecting NIRC......Skipped!
2013-09-30 03:32:18 [Common] Connecting Call Center(ID=30, Name=callcenter1)......
2013-09-30 03:32:18 [Common] Create CCS Connection......
com.huawei.icd.common.comm.cti.intf.PException: Expected UisAnyConnectAckMessage is null.
Change to back server and reconnect......
com.huawei.icd.common.comm.cti.intf.PException: Expected UisAnyConnectAckMessage is null.
Change to back server and reconnect......
2013-09-30 03:32:46 [Common] Create CCS Connection......Fail!
2013-09-30 03:32:46 [Common] Create Alert Connection......
2013-09-30 03:32:46 [Common] Create Alert Connection......Skipped!
2013-09-30 03:32:46 [Common] Create WFM(ID=1, Name=wfm1) Connection......
2013-09-30 03:32:46 [Common] Create WFM(ID=1, Name=wfm1) Connection......Skipped!
c. 进入“/home/cms/icdcomm/bin”目录。
cd /home/cms/icdcomm/bin
d. 重新启动ICDCOMM。
./stopcomm
./icdcomm

3. 修改CMS_Release/conf/was.xml文件。

a. 以cms用户登录CMS服务器。
b. 进入“/home/cms/CMS_Release/conf”目录。
cd /home/cms/CMS_Release/conf
c. 修改“was.xml”文件中的主备ccs的IP地址,如下所示:
                       .
                        .
                        .
<callcenters>
      <callcenter id="1" name="callcenter1">    //此处填写呼叫中心的ID和名称。
        <ccs>
          <main>
            <host>10.10.10.17</host>        //此处填写主用CCS IP地址。
            <port>20</port>
            <receive>20</receive>
            <byte-sequence>BigEndian</byte-sequence>
          </main>
          <back>
            <host>10.10.10.18</host>      //此处填写备用CCS IP地址。如果不存在备用CCS,此处请保持为空。
            <port>20</port>
            <receive>20</receive>
            <byte-sequence>BigEndian</byte-sequence>
          </back>
          <argument-ref>core-server-arg</argument-ref>
        </ccs>
                        .
                        .
                        .

4. 如果故障还未排除,请参考求助渠道获取帮助。
根因
可能原因:
  • WAS中没有配置CMS服务器的IP地址,导致服务启动CCS连接不上。
  • CMS服务使用的ICDCOMM没有启动。
  • CMS服务器上“was.xml”文件中的ccs主备地址错误。

END