CMS登录页面没有显示呼叫中心

发布时间:  2015-04-25 浏览次数:  314 下载次数:  0
问题描述
登录CMS时,首页面“呼叫中心”栏没有显示对应的呼叫中心名称,如图9-19所示。

图9-19 CMS首页面
处理过程
1. 检查Web配置台是否已经添加CMS的IP地址。

a. 以系统管理员登录Web配置台。
b. 选择“We配置台 > 系统配置 > WAS”。
c. 在“WAS”页签下,查看CMS的IP地址是否已经添加。
如果不存在,请单击“增加”进行添加。

2. 检查“was.xml”文件中呼叫中心信息是否正确。

a. 以cms用户登录CMS服务器。
b. 进入“/home/cms/CMS_Release/conf”目录。
cd /home/cms/CMS_Release/conf
c. 检查“was.xml”文件中呼叫中心的信息是否正确。
vi was.xml
呼叫中心信息字段如下所示:
<callcenter id="1" name="callcenter1"    //此处填写呼叫中心的ID和名称。 
       <ccs>           
         <main>
           <host>10.10.10.17</host>        //此处填写主用CCS IP地址。             
           <port>20</port>             
           <receive>20</receive>
           <byte-sequence>BigEndian</byte-sequence>       
         </main>           
         <back>
           <host>10.10.10.18</host>        //此处填写备用CCS IP地址。如果不存在备用CCS,此处请保持为空。             
           <port>20</port>
           <receive>20</receive>             
           <byte-sequence>BigEndian</byte-sequence>
         </back>           
         <argument-ref>core-server-arg</argument-ref>
       </ccs>
如果呼叫中心信息配置有误,请将其修改为正确的信息并保存。

3. 检查CMS侧的ICDComm是否正常启动。

a. 以cms用户登录CMS服务器。
b. 进入“/home/cms/icdcomm/log”。
cd /home/cms/icdcomm/log
c. 查看icdcomm的启动日志。
− 如果系统显示类似信息,表明ICDComm安装成功,并且已经正常启动:
cms@linuxhuawei:~/icdcomm/log> cat icdcomm.log
[20867: 2011-08-16 16:27:18]cfg file: /home/cms/icdcomm/config/icdcomm.cfg
[20867: 2011-08-16 16:27:18]Control file path: /hwshare
[20867: 2011-08-16 16:27:18]Identify self IP address[1]:10.10.10.31
[20868: 2011-08-16 16:27:18]Start ICDComm V3.0D340 (IPCKEY=12345678).
[20868: 2011-08-16 16:27:18]INFO:will reopen shm.last shmget info:2.
[20868: 2011-08-16 16:27:18]Start running......
[20868: 2011-08-16 16:27:18]Bind IP [10.10.10.31] port[8888] success.

− 如果系统显示信息与上述信息不同,请重启ICDComm。
cd /home/cms/icdcomm/bin
./stopcomm
./icdcomm

4. 检查CMS系统是否异常启停,导致读取信息失败。

a. 以cms用户登录CMS服务器。
b. 停止守护进程。
如果没有配置守护进程,请跳过此步骤。
cd /home/cms/CMS_Release/bin
./CMS_Daemon.sh stop
c. 停止CMS应用。
./stop_cms.sh
d. 等待至少10min。
e. 启动CMS应用。
以下情况二选一:
− 有守护进程场景:启动守护进程。
守护进程启动后,会自动启动CMS应用。
./CMS_Daemon.sh start
− 无守护进程场景:启动CMS应用。
./startup.sh
根因
可能原因:
  • Web配置台没有添加CMS的IP地址。
  • CMS系统的“was.xml”文件中没有配置相应的呼叫中心信息。
  • CMS侧的ICDComm没有正常启动。
  • CMS系统异常启停,导致读取信息失败。

END