AR2200 MPLS VPN option A/ASBR PE之间跑OSPF 学习不到对端的路由

发布时间:  2015-04-28 浏览次数:  308 下载次数:  0
问题描述


1.某个公司业务为mpls VPN option A组网,ASBR PE之间跑ospf. 发现互相学习不到的对端的路由。后来用模拟器模拟,同样的情况.

2.在AR2和AR3都能查看到对端发送过来的ospf lsdb。

关键的配置如下;

r1

ip vpn-instance ei
 ipv4-family
  route-distinguisher 1.1.1.1:111
  vpn-target 111:111 export-extcommunity
  vpn-target 111:111 import-extcommunity 
mpls lsr-id 1.1.1.1
mpls
mpls ldp
interface Ethernet0/0/0
 ip binding vpn-instance ei
 ip address 192.168.1.1 255.255.255.0
interface Ethernet0/0/1
 ip address 12.1.1.1 255.255.255.0
 mpls
 mpls ldp

interface LoopBack1
 ip address 1.1.1.1 255.255.255.255 
bgp 1
 peer 2.2.2.2 as-number 1
 peer 2.2.2.2 connect-interface LoopBack1
 ipv4-family unicast
  undo synchronization
  peer 2.2.2.2 enable
 ipv4-family vpnv4
  policy vpn-target
  peer 2.2.2.2 enable
 ipv4-family vpn-instance ei
  import-route direct
ip route-static 2.2.2.2 255.255.255.255 12.1.1.2

R2
interface Ethernet0/0/0
 ip address 12.1.1.2 255.255.255.0
 mpls
 mpls ldp 
interface Ethernet0/0/1
 ip binding vpn-instance ei
 ip address 23.1.1.2 255.255.255.0 
interface LoopBack1
 ip address 2.2.2.2 255.255.255.255
bgp 1
 peer 1.1.1.1 as-number 1
 peer 1.1.1.1 connect-interface LoopBack1 
 ipv4-family unicast
  undo synchronization
  peer 1.1.1.1 enable 
 ipv4-family vpnv4

 policy vpn-target
  peer 1.1.1.1 enable
ospf 1 vpn-instance ei
 import-route bgp permit-ibgp
 area 0.0.0.0
  network 23.1.1.0 0.0.0.255 
ip route-static 1.1.1.1 255.255.255.255 12.1.1.1 
 

 

R3 和R2配置对称的,R4和R1 配置对称的,

问题描述,

R2能收到R1发过来的BGP VPNV4路由,R3和R2通过ospf多实例建立邻居。 R3和R2的ospf邻居起来了,但是学习不到对端路由。

在R2能看到相关路由的lsdb,但是不加表

R2的ospf lsdb
[Huawei-ospf-1]display  ospf lsdb
  OSPF Process 1 with Router ID 23.1.1.2
   Link State Database
           Area: 0.0.0.0
Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
Router    23.1.1.3        23.1.1.3          1236  36    80000004       1
Router    23.1.1.2        23.1.1.2          1242  36    80000004       1
Network   23.1.1.3        23.1.1.3          1236  32    80000002       0 
   AS External Database
Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
External  192.168.1.0     23.1.1.2           487  36    80000001       1 =======================》》这个是通过BGP 注入到OSPF的
External  192.168.2.0     23.1.1.3           299  36    80000001       1 ========================》》》这个是R3通过过来的


处理过程

R2上5类LSA
[Huawei-ospf-1]display ospf lsdb ase
  OSPF Process 1 with Router ID 23.1.1.2
   Link State Database

  Type      : External
  Ls id     : 192.168.1.0
  Adv rtr   : 23.1.1.2 
  Ls age    : 517
  Len       : 36
  Options   :  E  DN 
  seq#      : 80000001
  chksum    : 0xced
  Net mask  : 255.255.255.0
  TOS 0  Metric: 1
  E type    : 2
  Forwarding Address : 0.0.0.0
  Tag       : 3489660929 =================》》》 OSPF多实例的情况,会检查route tag值,这个值是通过BGP的AS号生成的 
  Priority  : Low
  Type      : External
  Ls id     : 192.168.2.0
  Adv rtr   : 23.1.1.3 
  Ls age    : 329
  Len       : 36
  Options   :  E  DN =================》》》 可以看到该LSA的DNbit置位了
  seq#      : 80000001
  chksum    : 0xd0f6
  Net mask  : 255.255.255.0
  TOS 0  Metric: 1
  E type    : 2
  Forwarding Address : 0.0.0.0
  Tag       : 2
  Priority  : Low

R2上vpn下路由表
[Huawei-ospf-1]display ip routing-table  vpn-instance  ei
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: ei
         Destinations : 3        Routes : 3       
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
       23.1.1.0/24  Direct  0    0           D   23.1.1.2        Ethernet0/0/1
       23.1.1.2/32  Direct  0    0           D   127.0.0.1       Ethernet0/0/1
    192.168.1.0/24  IBGP    255  0          RD   1.1.1.1         Ethernet0/0/0

以上无192.168.2.0的路由


根因

最终定位
发现在MCE(Multi-VPN-Instance CE)设备上部署OSPF VPN多实例时。默认情况开启了防环检测.
这种情况下,通过配置vpn-instance-capability simple命令可以取消OSPF路由环路检测,不检查DN Bit和Route-tag而直接计算出所有OSPF路由,Route-tag恢复为缺省值1

使用Tag防环
对于type5、type7类LSA除了通过上面的DN-BIT可以防止路由环路外,还可以根据Tag值进行防环,即如果LSA的Tag值与本地(PE上)OSPF进程的Route tag相同,则这个LSA不参与到路由计算中。 由于防环检测的存在,所以我们在PE经常会发现存在LSA但路由计算不出来

由于R3通告给R2的LSA可以看到DN bit置位,R2会忽略这些LSA。此外route tag是这种情况是根据BGP的AS号生成的,(如果没有配置route-tag X和route-tag disable,但配置了BGP,则LSA的tag值为0xd0000000|BGP AS NUM ) 由于2边的AS号不一致,那么不影响路由学习.

 

 

END