U1960通过SIP中继跟AVAYA对接,话务台接听第二路通话后双音双不通

发布时间:  2015-05-06 浏览次数:  169 下载次数:  0
问题描述

现象描述

当从Avaya通过SIP中继拨打话务台时,话务员接听第一路通话正常,此时当第二路通话进来,话务员能听到振铃,可以接听,但是语音双不通。
   
当使用华为IP话机直接注册到U19XX上,拨打话务台时,话务员接听第一路通话正常,第二路通话也是正常的。

 

实际场景:

         AVAYA--------------U1960----------软话务台

用户号码12061201注册在AWAYA上。

用户号码2449是注册在U19XX上的话务员。

1. 1206 拨打2448
2. 2449
接听并与1206通话正常
3. 1201
拨打2449, 2449 振铃
4. 2449
保持1206, 接听1201,接听后无声音
5. 2449
又保持 1201 恢复与 1206通话

处理过程

分析过程

1.      在存在一路的情况下,第二路呼叫U19XX会发送183给对端。如果对端支持100rel并且允许UPDATE,则符合SIP协议的拓展内容,U19XX应该接着发送UPDATE更新媒体信息。

2.      通过抓取网络包查看信令流程。

第二路呼叫发送的INVITEsupport 100rel并且allow UPDATE

在存在一路呼叫时,SoftCo会返回183响应,并参与媒体协商。(下图为183携带SDP

此时U19XX理应发送UPDATE更新媒体信息,但是通过网络包发现发送200 OK给对端。

         对端设备在接收到200 OK后,没有修改RTP的参数,RTP发送和接收都未改变。

        

可能原因

1.      U19XX183响应之后没有发送UPDATA更新媒体信息,中继配置可能没有支持UPDATE

U19XXshow  peercomponent,若SupportUpdate参数为NO,则修改为YES


解决方案

处理步骤

步骤 1     SIP中继侧配置update

config  modify  peercomponent  domainname  l  ipmode  ipv4  support  update  yes

----结束

END