N8500 failed to expand data disk due to Thin LUN

Publication Date:  2015-06-25 Views:  199 Downloads:  0
Issue Description

Product Model: N8500

Version: V200R002C00SPC100

Problem Description:

 

The customer was having  LUN  with 5TB and Data Disk created on that LUN around the 5TB.

After the Data Disk reach 98.82% ,he added more 5 TB to the LUN and the Data disk increased to become 10 TB but with the same utilization percentage 98.82% and the file storage pool in all stages is the same 4.88 TB .

 

The scanbus error occur in the CLI and also from the ISM but without details.

Alarm Information

After expanding data disk by 5 TB extra the SIM show the same free space before expanding and the file storage pool has the same space , I tried to run Scanbus but it gives me the following error.

storagehw.Storage> scanbus
 0% [\] Scanning the bus for disks                                             

10% [|] Scanning the bus for disks                                             

20% [/] Scanning the bus for disks                                             

30% [-] Scanning the bus for disks                                             

35% [\] Scanning the bus for disks                                             

40% [|] Scanning the bus for disks                                             

50% [/] Scanning the bus for disks                                             

70% [-] Scanning the bus for disks                                             

75% [\] Scanning the bus for disks                                            
/opt/HS/scripts/hide_lunpoolfs/hidelunpoolfs_scanbus.sh: line 35: 13289 Killed                 

/opt/VRTSnasgw/scripts/scanbus.sh $*

storagehw_01:
S2600T scanbus ERROR V-288-23163 Scanning for data disks times out.

Handling Process

1: Ask the customer to feedback the LUN name which added to the data disk and collect the storage logs for the SAN;

2: The customer feedback the LUN name is "Veeam-Rep01" and feedback the storage logs.

3: From the logs,we find the customer create the data disk based on the Thin LUN:

        Thin LUN ID:11

        Thin LUN Name:Veeam-Rep01

        Thin Pool ID:0

         LUN WWN:61:05:17:21:00:4a:3c:ac:69:be:50:ed:00:00:00:0b

        Capacity(KB):10737418240

        Thin LUN Status:NORMAL

        Thin LUN Consumed Size(KB):4837081088

        Reclaim Process(%):--

        Current Owner:Controller in slot A

        Cache Write Policy:(Write back;Mirroring)

Root Cause

Thin LUN is not supported in the NAS, means when  creating the LUN for data disk, we have to choose thick LUN (common LUN).For the thin LUN, due to its own property, it  expands its capacity automatically, which will not be recognized by the File system in the NAS.

 

Solution

Create another file system with 10TB which is associated with common LUN , then copy the data in the original File system with Thin LUN to the new File system,at last, delete the old file system.

Because the data is inside the storage system , there is a fast way to copy data from the storage in stead of doing that by the client server.

 

Finish the copy on the NAS system like this:

1.       Create a new file system named “data1”, and the old one named “data”

2.      Login master NAS node with support account, run the command to copy the data from old file system to the new file system. (please keep the SSH session open all the time)

nohup rsync -aAXv /vx/data/ /vx/data1 >>/home/support/rsync_full.log &

Suggestions
When we create LUNs for data disks in NAS solution,we have to choose normal LUN.

END