Failure to Access the Contact Center by Dialing the Access Code

Publication Date:  2015-06-29 Views:  268 Downloads:  0
Issue Description
After dialing the access code for the contact center, customers may encounter one of the following scenarios:
 The call is disconnected immediately.
 The announcement indicating that the number they dialed does not exist is played.
 The busy tone is played.
 The announcement indicating that the system is faulty is played.
Handling Process
1. Verify that the following components in each pair can ping each other:
− Unified gateway and CTI-Link
− Unified gateway and file server
− CCS and Agent Server
− Agent Server and Agent Management service database
2. Check whether the carrier device sends the access code to the CTI platform.
If yes, go to the next step. If no, configure the carrier device correctly.
3. Verify that the unified gateway module number is correctly configured on the web configuration console.
To check the unified gateway module number, log in to the web configuration console as a system administrator and choose Web Configuration Console > System Configuration > CCS/Media Server > CTI Configuration > Basic Info.
4. Verify that the access code is correctly configured on the web configuration console.
To check the access code, log in to the web configuration console as a VDN administrator and choose Web Configuration Console > VDN1 Configuration > Called Party Configuration.
5. Check whether the Not Answer Incoming Call option is selected for agents on the web configuration console.
To check the Not Answer Incoming Call option, log in to the web configuration console as a VDN administrator and choose Web Configuration Console > VDN1 Configuration > Agent Role > Agent Role.
6. Check whether the unified gateway license supports call access to the CTI platform.
DSP LICENSE
Check the command output for the value of Access to CTI platform. If the value of Access to CTI platform is not TRUE, apply for a new license.
7. Check the CTI-Link connection status on the unified gateway.
− U2980 or U2990
DSP MEMLNK:MN=40;
In this command, the value 40 of MN= is the same as that of IFM module number in the command output of LST MEMLNK:;.
− If Socket connect status is Connect in the command output, the U2980 or U2990 has been correctly connected to the CTI-Link.
If Socket connect status is not Connect, rectify the fault by referring to 3.7 U2980/U2990 Disconnected from the CTI.
− If no command output is displayed, no CTI-Link information is configured on the U2980 or U2990. Run the ADD MEMLNK command to configure CTI-Link information on the U2980 or U2990.
− UAP3300
show ctinfo
− In the command output, if the CTI is in MASTER_SERVER state when the CTI is deployed in a single-node system, or if one CTI is in MASTER_SERVER state and the other is in SLAVE_SERVER state when the CTI is deployed in a two-node cluster, the UAP3300 has been correctly connected to the CTI-Link.
If the CTI is in abnormal state, rectify the fault by referring to 3.10 UAP3300 Disconnected from the CTI.
− If no command output is displayed, no CTI-Link information is configured on the UAP3300. Run the config add ctinfo command to configure CTI-Link information on the UAP3300.
8. Verify that the access code configured on the unified gateway is the same as that configured in 4.
− U2980 or U2990
− Check the access code.
LST CNACLD: PFX=K'1001;
In the command output that is displayed:
− If the value of Service category is value-added service, the access code is correctly configured on the U2980 or U2990.
− If the value of Service category is not value-added service, the access code is incorrectly configured on the U2980 or U2990. At this time, run the MOD CNACLD command to change the access code.
If no command output is displayed, run the ADD CNACLD command to configure the access code on the U2980 or U2990.
− Check the service console attributes of the access code for the maximum and minimum number length.
LST SRVATTR
If the maximum number length is different from the minimum number length, run the MOD SRVATTR command to modify.
− UAP3300
show prefix dn 1001
In the command output that is displayed:
− If the value of CallCategory is intess and the value of CallAttribute is inter, the access code is correctly configured on the UAP3300.
− If the value of either CallCategory or CallAttribute is incorrect, the access code is incorrectly configured on the UAP3300. At this time, run the config delete prefix command to delete the access code record and then run the config add prefix command to add the correct one.
If no command output is displayed, run the config add prefix command to configure the access code on the UAP3300.
9. Verify that the unified gateway is connected to the file server. If they are disconnected, rectify the fault by referring to 3.5 U2980/U2990 Disconnected from the File Server.
If the unified gateway is UAP3300, skip this step. This is because disconnection between the UAP3300 and the file server does not cause failure to access the contact center by dialing the access code
10. If the fault still persists, obtain help through the channels described in Help Channels.
Root Cause
 Network exceptions occur.
 The carrier device does not send the access code to the CTI platform.
 The module number of the unified gateway is not configured on the web configuration console.
 The access code is not configured as the called number on the web configuration console.
 On the web configuration console, Not Answer Incoming Call is selected for agents.
 The unified gateway license does not support call access to the CTI platform.
 The connection between the unified gateway and the CTI-Link is abnormal.
 No access code is configured on the unified gateway, or the access code configured on the unified gateway is different from that configured on the web configuration console.
 The unified gateway is disconnected from the file server.

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