交换机SPU板与主控板版本不一致导致无法注册

发布时间:  2015-06-29 浏览次数:  201 下载次数:  0
问题描述
某客户客户扩容一块SPU板卡,将单板插入S9300交换机后,从主控板观察到单板反复复位无法注册。
告警信息

观察交换机上的日志信息发现存在如下信息:

May 18 2015 18:31:13 S9306-01 %%01ALML/4/SPU_VERCOMP_FAIL(l)[105]: Slot= 1; SPU and VSW's version is not compatiable.

May 18 2015 18:29:39 S9306-01 %%01ALML/4/SPU_VERCOMP_FAIL(l)[106]:SPU[1/1] and MPU's version is not compatiable.

处理过程

1、从交换机上打印的日志信息可以看出,由于SPU单板的系统软件和交换机主控MPU的系统软件不匹配导致;

2、 在主控板上通过display version命令确认当前版本信息为V200R003C00SPC500;

3、由于SPU板无法注册,只能通过SPU的串口登录,通过反复重启的过程中可以发现,SPU尝试加载的是V200R001C00SPC300的版本,由此确定版本不一致。

根因
SPU板卡存在独立的操作系统软件,必须入交换机主控的软件版本保持匹配关系,可以参阅版本说明书获取,如果版本不一致,则无法注册成功。
解决方案

1、根据交换机主控的版本,查阅对应的版本说明书,找到SPU对应的版本号,并从华为企业技术支持网站http://support.huawei.com/enterprise/下载正确的软件;

2、通过SPU板串口进入BootROM菜单,重新上传正确版本的系统软件,并重新设置启动参数,然后重启,发现注册成功;

3、再次检查SPU板卡状态,发现注册成功;

建议与总结
对于SPU这一类具有独立操作系统的板卡,需要注意和主机本身的软件版本的兼容性。

END