Failed to Make Outgoing Calls Through the PRA Trunk

Publication Date:  2015-07-14 Views:  237 Downloads:  0
Issue Description
Version: eSpace U1980 V100R001C01SPC800

Network: U1980----E1 (PRA)----PSTN

Among the three office routes, outgoing calls fail on one office route. The busy tone is heard after dialing. Incoming calls can be made properly.
Handling Process
Step 1 Check the PRA trunk configuration. No error is found.

Step 2 Capture logs on the eSpace U1980. It is found that a PROGRESS message is received from the peer end in a failed call. The message contains the following information: Invalid number format (address incomplete).



Step 3 Capture outgoing call logs on a normal E1 line. Based on comparison with the Setup messages sent by the eSpace U1980, it is found that the calling and called numbers are of the same type.





Step 4 Capture logs for a successful incoming call, and analyze the Setup message sent by the peer end. It is found that the calling number type is National number and the called number type is Unknown.



Step 5 Change the calling and called number types for the PRA trunk to Unknown and National number. The fault persists.

Step 6 Ask the PSTN side to view the calling and called number types. The PSTN devices are old, and no information is obtained.

Step 7 Try to use other calling and called number types. When both the calling and called number types are set to Unknown, the fault is rectified. The command is as follows:
config protocol pra officeno 250 typeofcldnumber unknown typeofclinumber unknown

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Root Cause
Possible Cause:
  • The trunk configuration is incorrect.
  • Cooperation with the peer end at the signaling layer has a problem.
Suggestions
For interworking faults, analyze the faults together with the peer end. In special situations, try different parameter values based on analysis.

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