s12700与传输设备eth-trunk链路捆绑对接故障

发布时间:  2015-07-16 浏览次数:  135 下载次数:  0
问题描述

S12700和传输设备通过手动eth-trunk链路捆绑,双链路对接,开启eth-trunk后,数据不通

具体配置如下:

vlan batch 20 30

interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 20 30
 
interface GigabitEthernet1/0/1 
 eth-trunk 1
 
interface GigabitEthernet1/0/2 
 eth-trunk 1
告警信息

传输设备上提示未收到LACP报文

处理过程

1、更换交换机的两个接口进行eth-trunk捆绑,故障存在

2、使用display eth-trunk命令查看Eth-Trunk接口的配置信息,没有问题

3、使用ping命令测试网络通断,数据不通,将eth-trunk中的一个端口关闭,再次使用ping命令测试,可以ping通;开启此端口,关闭另一个端口再次ping测试,ping不通

3、因为传输设备提示未收到LACP报文,且咨询传输工程师后,表示传输设备的这两个捆绑的接口为一主一备模式,考虑是否传输设备只支持动态LACP,不支持手动静态eth-trunk

4、在eth-trunk接口视图下,使用命令mode  lacp,将交换机的链路捆绑模式改为动态LACP后,再次使用ping测试,可以ping通,此时两个做了链路捆绑的链路为主备模式。

最终配置如下:

interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 20 30
mode lacp # interface GigabitEthernet1/0/1 eth-trunk 1
 lacp priority 100
# interface GigabitEthernet1/0/2 eth-trunk 1
 lacp priority 100
根因

因为传输设备不支持手工eth-trunk链路捆绑,只支持动态LACP主备链路,所以交换机配置手工eth-trunk后,对端的传输设备因为LACP协议无法协商,故数据无法正常通信,将交换机开启LACP后,交换机与对端的传输设备可以正常协商LACP,数据可以正常通信

解决方案

数通设备与传输设备对接时,链路捆绑只能用动态LACP方式,不支持手动静态eth-trunk方式

建议与总结

传输设备不支持手动静态eth-trunk链路捆绑,只支持动态LACP主备链路,所以数通设备与传输设备对接时,链路捆绑只能用动态LACP方式

END