Datastation话单入库不成功,查询日志发现ICD_SERVICE表空间满

发布时间:  2015-07-22 浏览次数:  313 下载次数:  0
问题描述
某局点,CC平台运行了一段时间之后,突然发现Datastation话单入库不成功。
处理过程
1、 分析TAC从现场提取Datastation日志,查找入库失败信息。
发现是由于ICD_SERVICE表空间满导致入库失败。
[ctibill->oracle_realtime][2015-04-16 19:10:06][ERROR]Executing the destination sql failed. Error information:
ORA-06502: PL/SQL: 数字或值错误 :  字符串缓冲区太小
ORA-06512: 在 "ICD.P_DCS_PRESTATBILLLOG_V3R5C45", line 291
ORA-06502: PL/SQL: 数字或值错误 :  字符串缓冲区太小
ORA-06512: 在 "ICD.F_DAYLOG_DISPENSE", line 154
ORA-01653: 表 ICD.T_DAYLOG_ERRLOG 无法通过 128 (在表空间 ICD_SERVICE 中) 扩展 ORA-06512: 在 "ICD.F_DAYLOG_TRANSFERDATA", line 2480 ORA-01653: 表 ICD.T_DAYLOG_CALLANALYSIS 无法通过 128 (在表空间 ICD_SERVICE 中) 扩展
ORA-06512: 在 line 1 .
2、 查询ICD_SERVICE表空间下的数据表的记录数,并依此估算出占用的空间大小。
发现占用空间最大的是:两张HPS详单表(T_HPS_BILL_CALLHIS,T_HPS_CALL_DETAIL_RECORD)和两张UIDB的历史详单表(TAGENTCALLINFOHISTORY,TAGENTOPRINFOHISTORY)。
根因
问题原因
1、 该呼叫中心并没有使用HPS业务,但两张HPS详单表的数据量却十分庞大,这是eSpaceCC V200R001C03版本的一个已知问题,需要升级版本解决。
2、 两张UIDB的历史详单表数据量大,则是由于该平台运行时间较长以后的正常数据写入。需要定期清理来释放空间。
解决方案
步骤 1 升级到相应版本版本。
 有HPS业务,需升级到eSpace CC V200R001C31SPC302版本。
 无HPS业务,则:
1、C03系列版本升级到eSpace CC V200R001C03SPC205;
2、C31系列版本升级到eSpace CC V200R001C31SPC302。
步骤 2 将FAIL话单重新入库日结。
步骤 3 建议根据现场实际情况定期清理UIDB的历史数据,操作步骤详见《ICD 产品文档(For Engineer,ICD)》 > 例行维护 > 远程维护指导 > 日常维护操作。

END