eSpace U1960 CLIR (Calling line identification restriction) service case an outgoing call failed

Publication Date:  2015-07-31 Views:  388 Downloads:  0
Issue Description
One oversea customer reported that one user in the site cannot make an outgoing calls, other sites and other users can make outgoing calls normally.
Handling Process

1.       Check the network topology as below: U1960 is behind Firewall, and interconnected with PSTN via SIP trunk, FW act as a proxy server.

PSTN---FW---U1960---IP Phone

2.       Capture packet at FW, from the packet, FW already forward Invite message, but PSTN respond a 403 forbidden message.

3.       Check the invite message FW forwarded, we can found the From header is anonymous, which may be the reason PSTN refuse this call.

4.       Capture packet at U1960 side, and found IP phone have sent an correct calling number, but U1960 sent an anonymous calling number to FW, then check the service of this specific user, and can found this user have “Calling line identification restriction” service enabled.

Disable CLIR service on U1960 and test again, the outgoing call was made successful.
Root Cause
Because the user have CLIR service enabled on U1960, then U1960 sent out an anonymous calling number to PSTN, which case PSTN refused the call.
Solution
Disable CLIR service on U1960, and the issue was resolved.

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