AR路由器与其他厂商设备对接时建立BGP连接失败

发布时间:  2015-08-19 浏览次数:  438 下载次数:  0
问题描述
版本信息:V200R005C20SPC200

组网概述:AR161经过交换机和远端其他厂商设备对接,设备间建立BGP连接。

图1-1 组网图



配置文件如下:

ip vpn-instance MGMT
ipv4-family
ipv6-family
#
ip vpn-instance VPN1
ipv4-family
  route-distinguisher 64512:201
ipv6-family
#
interface Vlanif21
ip binding vpn-instance VPN1
ip address 172.16.1.1 255.255.255.0
dhcp select interface
dhcp server excluded-ip-address 172.16.1.2 172.16.1.25
dhcp server dns-list 193.150.193.150 83.255.245.11
#
interface GigabitEthernet0/0/0
shutdown
#
interface GigabitEthernet0/0/1
shutdown
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 21
port hybrid tagged vlan 22 to 25
port hybrid untagged vlan 21
undo lldp enable
#
interface GigabitEthernet0/0/3
shutdown
undo lldp enable
#
interface GigabitEthernet0/0/4
ip binding vpn-instance MGMT
ip address 172.16.49.50 255.255.255.224
combo-port auto
#
interface GigabitEthernet0/0/4.201
dot1q termination vid 201
ip binding vpn-instance VPN1
ip address 83.x.x.1 255.255.255.254
#
interface Cellular0/0/0
shutdown
#
bgp 64512
timer keepalive 10 hold 70
#
ipv4-family unicast
  undo synchronization
#
ipv4-family vpn-instance VPN1
  default-route imported
  import-route direct
  import-route static
  peer 83.x.x.0 as-number 39651
  peer 83.x.x.0 ebgp-max-hop 2
  peer 83.x.x.0 connect-interface GigabitEthernet0/0/4.201
  peer 83.x.x.0 password cipher @%@%k]7J;SbeIMzF>}B8O+}<wB4)@%@%
  peer 151.x.x.1 as-number 39651
  peer 151.x.x.1 ebgp-max-hop 2
  peer 151.x.x.1 connect-interface Virtual-Template3
  peer 151.x.x.1 password cipher @%@%f`IJGC%G<"j:aLBx2%&YwBEw@%@%
#
ip route-static vpn-instance MGMT 0.0.0.0 0.0.0.0 172.x.x.33 track nqa WAN WAN
ip route-static vpn-instance MGMT 172.16.111.0 255.255.255.0 172.16.49.33

故障现象:AR重启后同Cisco建立BGP链接失败。
处理过程
步骤 1 检查AR设备重启后配置是否丢失。

分析重启后BGP的配置,未发现明显问题。

步骤 2 在诊断视图下,执行命令display diagnostic-information查看设备信息。

发现在查询结果中有socket错误日志:OutBuffer Not available。经过确认,该错误日志是已知错误,但不影响BGP的建立,可以忽略这个异常。

步骤 3 分析系统启动时TCP和BGP模块的debug信息,分析BGP启动流程。

发现AR同对端设备间可以正常建立BGP的TCP连接,说明链路没有问题。

步骤 4 尝试在AR设备上添加Loopback接口并配置IP地址为192.168.1.2,Loopback接口添加成功后BGP正常可以链接,故障解决。

对比建立BGP前后的会话信息,失败时BGP local router ID为0.0.0.0,而成功时BGP local router ID的地址为Loopback接口地址192.168.1.2,如下所示。

<Huawei> display bgp vpnv4 vpn-instance VPN1 peer
BGP local router ID : 192.168.1.2
Local AS number : 64512
VPN-Instance VPN1, router ID 192.168.1.2: 
Total number of peers : 1                 Peers in established state : 1
  Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State   PrefRcv
  83.255.231.1    4 39651      10      22     0   02:59:49  Established       1
根因
在实际设备上,Router-id值为0.0.0.0是非法的。本端CR timer超时后,当检测到Router-id为0时,不会发起TCP连接;当收到对端连接后检测Router-id为0时,会关闭BGP连接。
解决方案
在AR设备上进行以下几种配置中的一种:
  • 执行router id router-id命令配置全局Route-id。
  • 执行interface loopback loopback-number命令新增Loopback接口及相应的IP地址。
  • 确保所有配置有IP地址的接口至少有一个不属于VPN-Instance。
建议与总结
建议每次配置BGP时,首先配置Route-id,防止默认选不到地址的情况。

END