桌面云无法运行firefly软件

发布时间:  2015-09-10 浏览次数:  149 下载次数:  0
问题描述

由于桌面云必须安装.net framework 4.0,而firefly运行时必须调用.net framework v1.1.4322,当安装有更高版本的.net framework,firefly会自动调用高版本的.net framework,导致无法运行firefly软件。需添加.config文件将程序运行时调用.net framework锁定到指定版本。

处理过程

可以在"..\Firefly\Client\bin"目录下新建一个txt文件,将以下的内容复制到新建的txt文本中,


<?xml version ="1.0"?>  

<configuration>  

<startup>  

<supportedRuntime version="v1.1.4322" />  

</startup>  

</configuration>


并复制成4份,分别命名为"firefly_client.exe.config","client_setting.exe.config","firefly_admin.exe.config"和"server_explorer.exe.config"文件,

在运行"firefly_client.exe","client_setting.exe","firefly_admin.exe.config"和"server_explorer.exe"程序验证是否成功。如不成功,即其他原因造成,需另外在排查。

END