CE12800产品LACP模式下单链路故障导致OSPF邻居中断

发布时间:  2015-09-18 浏览次数:  659 下载次数:  0
问题描述

1、4台CE12808设备,每两台做堆叠。堆叠后将设备命名为A设备和B设备。(A设备分为A-1和A-2,B设备分为B-1和B-2)

2、创建vlan2291,并配置链路协议为点到点的OSPF协议。
A设备配置如下:
interface Vlanif2291
description To-B
ip address 10.231.254.241 255.255.255.248
ospf cost 100
ospf network-type p2p

B设备配置如下:
interface Vlanif2291
description To-A
ip address 10.231.254.246 255.255.255.248
ospf cost 100
ospf network-type p2p

3、A-1和A-2设备分别出一根线链接到B-1和B-2设备。两条链路做捆绑为Eth-Trunk1,将Eth-Trunk1设为默认vlan 2291,并且使用LACP协议。
A设备配置:
#
interface Eth-Trunk1
description To-B
port default vlan 2291
mode lacp-static
#
interface 10GE1/2/0/5
description To-B-GE1/2/0/5
eth-trunk 1   
lacp priority 100
#
interface 10GE2/2/0/5
description To-B-GE2/2/0/5
eth-trunk 1   
lacp priority 100
B设备配置如下:
#
interface Eth-Trunk1
description To-A
port default vlan 2291
mode lacp-static
#
interface 10GE1/2/0/5
description To-A-GE1/2/0/5
eth-trunk 1   
lacp priority 100
#
interface 10GE2/2/0/5
description To-A-GE2/2/0/5
eth-trunk 1   
lacp priority 100

4、配置完之后,当其中一条链路断开之后,OSPF邻居也断开了。过一会又重新建立了OSPF邻居。 

告警信息

1、设备会先发出OSPF邻居断开的告警信息到网管;
2、再发送一条LACP协议断开的告警信息到网管;
3、再发送一条ospf协议起来的告警信息到网管;
4、再发送一条LACP协议起来的告警信息到网管;
业务恢复。

处理过程

在A上增加一条蓝色粗体的配置:
interface Eth-Trunk1
description To-B
port default vlan 2291
mode lacp-static
lacp timeout fast

在B上增加一条蓝色粗体的配置:
interface Eth-Trunk1
description To-B
port default vlan 2291
mode lacp-static
lacp timeout fast

根因

1、Ospf协议缺省情况下,P2P类型接口发送Hello报文的时间间隔的值为10秒,OSPF邻居超时时间为40秒。
2、LACP模式默认选择超时参数slow,对应LACP协议报文的超时时间缺省值是90s。
3、当一条链路断开后,接口的OSPF协议会先超时,LACP会后超时。导致OSPF在LACP超时前已经断开邻居关系。

解决方案

LACP模式下,选择参数fast,对端发送LACP报文的周期是1秒,指定LACP模式下Eth-Trunk接口接收报文的超时时间是3秒。 所以将接口LACP模式改为fast即可解决此问题。

建议与总结

以后遇到此部署场景时需要关注定时器的关联关系,避免类似问题发生。

END