VRP5平台Eth-trunk成员口BFD问题

发布时间:  2015-09-21 浏览次数:  195 下载次数:  0
问题描述


某局点想提高链路带宽及防止单条链路故障,提高网络可靠性,配置eth-trunk;

但是为了防止eth-trunk成员口链路状态UP,但是成员口不转发数据问题,导致流量丢失;因此希望配置eth-trunk成员口BFD;

组网如下:

两台NE40E-X16组成,GE1/0/0及GE2/0/0为eth-trunk 1成员口,三层互联;

设备版本及补丁如下:

<NE40E-X16-A> dis ver
Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.160 (NE40E&80E V600R008C10SPC300)
Copyright (C) 2000-2014 Huawei Technologies Co., Ltd.
HUAWEI NE40E-X16 uptime is 0 day, 0 hour, 39 minutes
Patch version : V600R008SPH018

A设备的主要配置如下:

#
bfd
#

#
interface Eth-Trunk1
description TO-BJ-KTY-NE40E-B-eth-trunk1
ip address 10.33.9.25 255.255.255.248
#

#
interface GigabitEthernet1/0/0
description TO-BJ-KTY-NE40E-B-GE1/0/0
undo shutdown
eth-trunk 1
dcn
#

interface GigabitEthernet2/0/0
description TO-BJ-KTY-NE40E-B-GE2/0/0
undo shutdown
eth-trunk 1
dcn                                     
#

 

#
bfd A2B-GE1/0/0 bind peer-ip 10.33.9.25 interface GigabitEthernet1/0/0
discriminator local 7001
discriminator remote 6001
process-interface-status
#
bfd A2B-GE2/0/0 bind peer-ip 10.33.9.25 interface GigabitEthernet2/0/0
discriminator local 7002
discriminator remote 6002
process-interface-status

#

 

B设备的主要配置如下:

#
bfd
#

#
interface Eth-Trunk1
description TO-BJ-KTY-NE40E-A-eth-trunk1
ip address 10.33.9.26 255.255.255.248
#

#
interface GigabitEthernet1/0/0
description TO-BJ-KTY-NE40E-A-GE1/0/0
undo shutdown                           
eth-trunk 1
dcn
#

interface GigabitEthernet2/0/0
description TO-BJ-KTY-NE40E-A-GE2/0/0
undo shutdown
eth-trunk 1
dcn
#

bfd B2A-GE1/0/0 bind peer-ip 10.33.9.25 interface GigabitEthernet1/0/0
discriminator local 7001
discriminator remote 6001
process-interface-status
#
bfd B2A-GE2/0/0 bind peer-ip 10.33.9.25 interface GigabitEthernet2/0/0
discriminator local 7002
discriminator remote 6002
process-interface-status

#

 

查看BFD session ,无session 会话;

告警信息

display bfd session all

查看不到BFD会话信息

处理过程

1、在A设备上,display arp all,可以看到10.33.9.26的arp信息,ping 10.33.9.26 可以通;说明eth-trunk是UP的,eth-trunk没有问题;

2、display eth-trunk 1,成员端口的状态都正常;说明端口都是UP,没有问题;

3、display bfd interface,可以看到bfd interface 包含eth-trunk 的两个成员口,这也没有问题;

4、display bfd session all,查看不到任何信息,说明bfd 会话有问题;

经确认,V5平台的bfd配置必须commit才能生效;

将两个设备上的bfd实例下执行commit;

display bfd session all 可以看到bfd 会话信息正常;

问题得到解决; 

根因
VRP5平台下的bfd必须执行commit才能生效,NE40E版本V6R8是基于VRP5平台下,因此创建BFD会话时,必须执行commit才能生效.
解决方案

在两端设备创建的bfd 实例下执行commit命令

 

建议与总结
NE40E版本V6R8是基于VRP5平台下,因此创建BFD会话时,必须执行commit才能生效.

END