S5700交换机dot1x认证和guest vlan配置方法

发布时间:  2015-09-26 浏览次数:  687 下载次数:  0
问题描述
PC——S5710——CE5810——policy center,用户配置了dot1x认证后,dot1x认证和guest vlan不能同时实现
处理过程
在S5710上做如下配置,能做dot1x认证,但guest vlan不生效:
interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
dot1x enable
authentication guest-vlan 200
dot1x authentication-method eap

在S5710上修改成如下配置,guest vlan能成功加入,但认证时提示配置错误,而且重新把PC网线插拔后,guest vlan和dot1x认证均不能正常使用:
interface GigabitEthernet0/0/1
port link-type hybrid
port hybrid tagged vlan 100
dot1x enable
authentication guest-vlan 200
dot1x authentication-method eap
解决方案

改成如下配置后,dot1x认证和guest vlan都能正常使用:

interface GigabitEthernet0/0/1
port hybrid pvid vlan 100
port hybrid untagged vlan 100 200
dot1x enable
authentication guest-vlan 200
dot1x authentication-method eap

END