Ultrapath V100R006C00SPC500 在linux上无法启动

发布时间:  2015-09-29 浏览次数:  288 下载次数:  0
问题描述
存储上有“主机未安装多路径ultrapath或多路径版本过低”的告警,在主机上发现多路径软件未运行。
告警信息

存储上有“主机未安装多路径ultrapath或多路径版本过低”的告警。


在主机上运行命令hot_add扫盘,提示Ultrapath模块未加载。

cid:image006.png@01D0F616.BE6778F0

处理过程

在主机上搜集多路径软件日志,分析后发现在多路径日志result\opt\UltraPath\log\ultrapathTool.log里面有大量读取操作系统版本的报错,无法读取到操作系统版本。

在主机上执行命令:cat /etc/issue 提示这个文件不存在。客户对服务器做了安全加固,为了不泄露操作系统版本信息,把/etc/issue文件改名为了/etc/issue.bak

根因
多路径软件在启动的时候会读取操作系统版本信息,如果这个文件被移走或无法读取,会导致多路径模块无法加载。linux下常见的存放版本信息的文件:/etc/issu或者/etc/redhat-release或者/etc/SuSe-release。
解决方案

把/etc/issue文件恢复,重启服务器加载多路径软件。

END