CE12800产品链路负载均衡出现不均衡故障

发布时间:  2015-10-26 浏览次数:  242 下载次数:  0
问题描述

1、4台CE12808设备,每两台做堆叠。堆叠后将设备命名为A设备和B设备。(A设备分为A-1和A-2,B设备分为B-1和B-2)

 

2、创建vlan2291。
A设备配置如下:
interface Vlanif2291
description To-B
ip address 10.231.254.241 255.255.255.248

B设备配置如下:
interface Vlanif2291
description To-A
ip address 10.231.254.246 255.255.255.248

3、A-1和A-2设备分别出一根线链接到B-1和B-2设备。两条链路做捆绑为Eth-Trunk1,将Eth-Trunk1设为默认vlan 2291,并且使用LACP协议。
A设备配置:
#
interface Eth-Trunk1
description To-B
port default vlan 2291
mode lacp-static
#
interface 10GE1/2/0/5
description To-B-GE1/2/0/5
eth-trunk 1   
lacp priority 100
#
interface 10GE2/2/0/5
description To-B-GE2/2/0/5
eth-trunk 1   
lacp priority 100
B设备配置如下:
#
interface Eth-Trunk1
description To-A
port default vlan 2291
mode lacp-static
#
interface 10GE1/2/0/5
description To-A-GE1/2/0/5
eth-trunk 1   
lacp priority 100
#
interface 10GE2/2/0/5
description To-A-GE2/2/0/5
eth-trunk 1   
lacp priority 100

4、配置完之后,当进行业务访问时,发现流量都从A设备的10GE1/2/0/5接口流出,两条链路的流量不均衡。

告警信息
处理过程

在A和B设备的接口eth-trunk 1修改一下配置参数:

1、A设备修改如下:

interface eth-trunk 1
  local-preference disable

2、B设备修改如下:

interface eth-trunk 1
 local-preference disable

修改完成后即可看到业务流量访问正常!

根因
堆叠设备默认本身开启了本地优先转发功能,导致流量到达A设备后优先从A-1设备转发出去,没有负载到A-2设备。从而流量没有得到负载分担。
解决方案
将堆叠设备的默认本地优先转发功能去使能即可实现流量的负载分担。
建议与总结
使能和去使能堆叠设备的本地优先转发功能需要根据客户的业务实际情况来进行修改,建议在客户的要求下进行修改。

END