S7700交换机组建VRRP冗余组播网络

发布时间:  2015-11-04 浏览次数:  1052 下载次数:  0
问题描述
组网需求
如图1-1所示,使用S7700(V200R005版本)作为园区网关出口与核心设备,组播源通过PE接入园区网。从横向看,网络关键节点实现了可靠冗余;从纵向看,出口网关与核心设备的全连接结构,实现了链路间的冗余备份。要求通过在出口网关和核心设备进行一定配置,确保组播数据能够正常可靠的传输到下游网络。






解决方案

1.2 配置思路

通过配置VRRPBFD特性保证组播数据在出口网关、核心设备传输的可靠性,配置组

播协议实现组播数据在出口网关、核心设备正常转发:

1. S7700-1S7700-2 之间,S7700-3S7700-4之间配置链路聚合,保证VRRP协议报文交互的通畅与可靠, 能够正常运行。

2. 各设备上创建VLAN,接口加入VLAN,对应VLANIF接口配IP地址,使本地达网络可达。

3. 各设备上配置OSPF路由协议,达到网络层互通。出口网关与核心层间实现单播转

发的负载均衡,减轻单链路同时转发单播数据和组播数据的压力。

4. S7700-1S7700-2 之间,S7700-3S7700-4之间配VRRP备份组,实现设备间冗余备份,确保组播数据可靠转发。不同备份组间实现单播转发的负载均衡,减轻单设备同时转发单播数据和组播数据的压力。

5. 各设备上配置组播协议,实现组播数据正常转发。

6. 各设备上配置BFD for OSPFBDF for PIM ,确保设备能快速感知链路故障,单播

路由、组播路由快速收敛。

1.2 配置步骤

步骤 1 配置链路聚合。

# 在所有设备上创建 接口并加入成员接口。

<S7700-1>system-view

[S7700-1]interface Eth-Trunk 1

[S7700-1-Eth-Trunk1]trunkport GigabitEthernet 2/0/1 to 2/0/3

[S7700-1-Eth-Trunk1]quit

<S7700-2>system-view

[S7700-2]interface Eth-Trunk 1

[S7700-2-Eth-Trunk1]trunkport GigabitEthernet 2/0/1 to 2/0/3

[S7700-2-Eth-Trunk1]quit

<S7700-3>system-view

[S7700-3]interface Eth-Trunk 1

[S7700-3-Eth-Trunk1]trunkport GigabitEthernet 2/0/1 to 2/0/3

[S7700-3-Eth-Trunk1]quit

<S7700-4>system-view

[S7700-4]interface Eth-Trunk 1

[S7700-4-Eth-Trunk1]trunkport GigabitEthernet 2/0/1 to 2/0/3

[S7700-4-Eth-Trunk1]quit

缺省情况下, 的工作模式为手工负载分担模式,所有活动接口都参与数据

的转发,分担负载流量。

步骤 2 创建VLAN,配置接口加入VLAN,三层接口配IP地址。

a. 在所有设备上创建VLAN,配置接口加入VLANS7700-2S7700-3S7700-4上的配置与S7700-1上的配置相似,配置过程略。

说明

S7700的二层接口默认使能STP。如果当前二层网络为环形组网,STP会将其中的一个端口阻塞以防止环路。在本配置示例中,S7700-3S7700-4和下游二层交换机已经构成了二层环网。为了不影响后面OSPF路由负载分担功能,建议S7700-3S7700-4去使能与下游二层交换机相连的二层接口上的STP功能。同时可在下游的二层交换机上配置Smart Link负载分担功能,确保二层环网不会广播风暴的同时,还能实现链路的负载分担。

[S7700-1] vlan batch 100 200 301 302

[S7700-1] interface gigabitethernet 1/0/0

[S7700-1-GigabitEthernet1/0/0] port link-type trunk

[S7700-1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100

[S7700-1-GigabitEthernet1/0/0] quit

[S7700-1] interface gigabitethernet 3/0/1

[S7700-1-GigabitEthernet3/0/1] port link-type trunk

[S7700-1-GigabitEthernet3/0/1] port trunk allow-pass vlan 301

[S7700-1-GigabitEthernet3/0/1] quit

[S7700-1] interface gigabitethernet 3/0/2

[S7700-1-GigabitEthernet3/0/2] port link-type trunk

[S7700-1-GigabitEthernet3/0/2] port trunk allow-pass vlan 302

[S7700-1-GigabitEthernet3/0/2] quit

[S7700-1] interface eth-trunk 1

[S7700-1-Eth-Trunk1] port link-type trunk

[S7700-1-Eth-Trunk1] port trunk allow-pass vlan 200

[S7700-1-Eth-Trunk1] quit

b. 在所有设备上的三层接口上配置IP地址。S7700-2S7700-3S7700-4上的配置

S7700-1上的配置相似,配置过程略。

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] ip address 10.1.1.1 24

[S7700-1-Vlanif100] quit

[S7700-1] interface vlanif 301

[S7700-1-Vlanif301] ip address 10.1.2.1 24

[S7700-1-Vlanif301] quit

[S7700-1] interface vlanif 302

[S7700-1-Vlanif302] ip address 10.1.3.1 24

[S7700-1-Vlanif302] quit

[S7700-1] interface loopback 1

[S7700-1-LoopBack1] ip address 1.1.1.1 32

[S7700-1-LoopBack1] quit

步骤 3 配置OSPF路由协议

# 在所有设备上使能OSPF,设备加入Area 0,配置Area 0内需要发布的网段。

S7700-2S7700-3S7700-4上的配置与S7700-1上的配置相似,配置过程略。

[S7700-1] ospf

[S7700-1-ospf-1] area 0

[S7700-1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[S7700-1-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255

[S7700-1-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255

[S7700-1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0

[S7700-1-ospf-1-area-0.0.0.0] quit

[S7700-1-ospf-1] quit

步骤 4 配置VRRP备份组。

a. S7700-1S7700-2上创建VRRP备份组1,配置S7700-1的优先级为120,抢占延时为20秒,作为Master设备;S7700-2的优先级为缺省值,作为Backup设备。

# 配置S7700-1

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.253

[S7700-1-Vlanif100] vrrp vrid 1 priority 120

[S7700-1-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20

[S7700-1-Vlanif100] quit

# 配置S7700-2

[S7700-2] interface vlanif 100

[S7700-2-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.253

[S7700-2-Vlanif100] quit

b. S7700-1S7700-2上创建VRRP备份组2,配置S7700-2的优先级为120,抢占延时为20秒,作为Master设备;S7700-1的优先级为缺省值,作为Backup设备。

# 配置S7700-1

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] vrrp vrid 2 virtual-ip 10.1.1.254

[S7700-1-Vlanif100] quit

# 配置S7700-2

[S7700-2] interface vlanif 100

[S7700-2-Vlanif100] vrrp vrid 2 virtual-ip 10.1.1.254

[S7700-2-Vlanif100] vrrp vrid 2 priority 120

[S7700-2-Vlanif100] vrrp vrid 2 preempt-mode timer delay 20

[S7700-2-Vlanif100] quit

S7700-3S7700-4的配置步骤与S7700-1S7700-2的配置步骤类似,配置过程略。

步骤 5 配置组播协议。

a. 在所有设备上使能组播路由功能,三层接口上使能PIM-SM,在用户侧接口上使能IGMP

# 配置S7700-1

[S7700-1] multicast routing-enable

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] pim sm

[S7700-1-Vlanif100] quit

[S7700-1] interface vlanif 301

[S7700-1-Vlanif301] pim sm

[S7700-1-Vlanif301] quit

[S7700-1] interface vlanif 302

[S7700-1-Vlanif302] pim sm

[S7700-1-Vlanif302] quit

[S7700-1] interface loopback 1

[S7700-1-LoopBack1] pim sm

[S7700-1-LoopBack1] quit

# 配置S7700-2

[S7700-2] multicast routing-enable

[S7700-2] interface vlanif 100

[S7700-2-Vlanif100] pim sm

[S7700-2-Vlanif100] quit

[S7700-2] interface vlanif 304

[S7700-2-Vlanif304] pim sm

[S7700-2-Vlanif304] quit

[S7700-2] interface vlanif 305

[S7700-2-Vlanif305] pim sm

[S7700-2-Vlanif305] quit

[S7700-2] interface loopback 1

[S7700-2-LoopBack1] pim sm

[S7700-2-LoopBack1] quit

# 配置S7700-3

[S7700-3] multicast routing-enable

[S7700-3] interface vlanif 400

[S7700-3-Vlanif100] pim sm

[S7700-3-Vlanif100] igmp enable

[S7700-3-Vlanif100] quit

[S7700-3] interface vlanif 301

[S7700-3-Vlanif304] pim sm

[S7700-3-Vlanif304] quit

[S7700-3] interface vlanif 302

[S7700-3-Vlanif305] pim sm

[S7700-3-Vlanif305] quit

[S7700-3] interface loopback 1

[S7700-3-LoopBack1] pim sm

[S7700-3-LoopBack1] quit

# 配置S7700-4

[S7700-4] multicast routing-enable

[S7700-4] interface vlanif 400

[S7700-4-Vlanif100] pim sm

[S7700-4-Vlanif100] igmp enable

[S7700-4-Vlanif100] quit

[S7700-4] interface vlanif 303

[S7700-4-Vlanif304] pim sm

[S7700-4-Vlanif304] quit

[S7700-4] interface vlanif 304

[S7700-4-Vlanif305] pim sm

[S7700-4-Vlanif305] quit

[S7700-4] interface loopback 1

[S7700-4-LoopBack1] pim sm

[S7700-4-LoopBack1] quit

b. 配置动态RP

# 配置S7700-3Loopback1接口为C-BSRC-RP接口。

[S7700-3] pim

[S7700-3-pim] c-bsr interface loopback 1

[S7700-3-pim] c-rp interface loopback 1

[S7700-3-pim] quit

# 配置S7700-4Loopback1接口为C-BSRC-RP接口。

[S7700-3] pim

[S7700-4-pim] c-bsr interface loopback 1

[S7700-4-pim] c-rp interface loopback 1

[S7700-4-pim] quit

步骤 6 配置BFD功能。

a. 在所有设备上使能全局BFD功能。全局BFD功能是配置BFD for OSPFBFD for PIM的前提。S7700-2S7700-3S7700-4上的配置与S7700-1上的配置相似,配置过程略。

[S7700-1] bfd

[S7700-1-bfd] quit

b. 在所有设备上配置BFD for OSPF功能。S7700-2S7700-3S7700-4上的配置与S7700-1上的配置相似,配置过程略。

[S7700-1] ospf

[S7700-1-ospf-1] bfd all-interfaces enable

[S7700-1-ospf-1] quit

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] ospf bfd enable

[S7700-1-Vlanif100] quit

[S7700-1] interface vlanif 301

[S7700-1-Vlanif301] ospf bfd enable

[S7700-1-Vlanif301] quit

[S7700-1] interface vlanif 302

[S7700-1-Vlanif302] ospf bfd enable

[S7700-1-Vlanif302] quit

c. 在所有设备上配置BFD for PIM功能。S7700-2S7700-3S7700-4上的配置与S7700-1上的配置相似,配置过程略。

[S7700-1] interface vlanif 100

[S7700-1-Vlanif100] pim bfd enable

[S7700-1-Vlanif100] quit

[S7700-1] interface vlanif 301

[S7700-1-Vlanif301] pim bfd enable

[S7700-1-Vlanif301] quit

[S7700-1] interface vlanif 302

[S7700-1-Vlanif302] pim bfd enable

[S7700-1-Vlanif302] quit

配置文件

7700-1的配置文件

sysname S7700-1

#

vlan batch 100 200 301 302

#

multicast routing-enable

#

bfd

#

interface Vlanif100

ip address 10.1.1.1 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.1.253

vrrp vrid 1 priority 120

vrrp vrid 1 preempt-mode timer delay 20

vrrp vrid 2 virtual-ip 10.1.1.254

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif301

ip address 10.1.2.1 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif302

ip address 10.1.3.1 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 200

#

interface GigabitEthernet1/0/0

port link-type trunk

port trunk allow-pass vlan 100

#

interface GigabitEthernet2/0/1

eth-trunk 1

#

interface GigabitEthernet2/0/2

eth-trunk 1

#

interface GigabitEthernet2/0/3

eth-trunk 1

#

interface GigabitEthernet3/0/1

port link-type trunk

port trunk allow-pass vlan 301

#

interface GigabitEthernet3/0/2

port link-type trunk

port trunk allow-pass vlan 302

#

interface LoopBack1

ip address 1.1.1.1 255.255.255.255

pim sm

#

ospf 1

bfd all-interfaces enable

area 0.0.0.0

network 1.1.1.1 0.0.0.0

network 10.1.1.0 0.0.0.255

network 10.1.2.0 0.0.0.255

network 10.1.3.0 0.0.0.255

#

return

S7700-2的配置文件

sysname S7700-2

#

vlan batch 100 200 303 304

#

multicast routing-enable

#

bfd

#

interface Vlanif100

ip address 10.1.1.2 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.1.253

vrrp vrid 2 virtual-ip 10.1.1.254

vrrp vrid 2 priority 120

vrrp vrid 2 preempt-mode timer delay 20

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif303

ip address 10.1.4.1 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif302

ip address 10.1.5.1 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 200

#

interface GigabitEthernet1/0/0

port link-type trunk

port trunk allow-pass vlan 100

#

interface GigabitEthernet2/0/1

eth-trunk 1

#

interface GigabitEthernet2/0/2

eth-trunk 1

#

interface GigabitEthernet2/0/3

eth-trunk 1

#

interface GigabitEthernet3/0/1

port link-type trunk

port trunk allow-pass vlan 303

#

interface GigabitEthernet3/0/2

port link-type trunk

port trunk allow-pass vlan 304

#

interface LoopBack1

ip address 2.2.2.2 255.255.255.255

pim sm

#

ospf 1

bfd all-interfaces enable

area 0.0.0.0

network 2.2.2.2 0.0.0.0

network 10.1.1.0 0.0.0.255

network 10.1.4.0 0.0.0.255

network 10.1.5.0 0.0.0.255

#

return

S7700-3的配置文件

sysname S7700-3

#

vlan batch 301 303 400 500

#

multicast routing-enable

#

bfd

#

interface Vlanif301

ip address 10.1.2.2 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif303

ip address 10.1.5.1 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif400

ip address 10.1.6.1 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.6.253

vrrp vrid 1 priority 120

vrrp vrid 1 preempt-mode timer delay 20

vrrp vrid 2 virtual-ip 10.1.6.254

pim sm

pim bfd enable

igmp enable

ospf bfd enable

#

interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 500

#

interface GigabitEthernet1/0/0

port link-type trunk

port trunk allow-pass vlan 400

stp disable

#

interface GigabitEthernet2/0/1

eth-trunk 1

#

interface GigabitEthernet2/0/2

eth-trunk 1

#

interface GigabitEthernet2/0/3

eth-trunk 1

#

interface GigabitEthernet3/0/1

port link-type trunk

port trunk allow-pass vlan 301

#

interface GigabitEthernet3/0/2

port link-type trunk

port trunk allow-pass vlan 303

#

interface LoopBack1

ip address 3.3.3.3 255.255.255.255

pim sm

#

ospf 1

bfd all-interfaces enable

area 0.0.0.0

network 3.3.3.3 0.0.0.0

network 10.1.2.0 0.0.0.255

network 10.1.4.0 0.0.0.255

network 10.1.6.0 0.0.0.255

#

pim

c-bsr LoopBack1

c-rp LoopBack1

#

return

S7700-4的配置文件

sysname S7700-4

#

vlan batch 302 304 400 500

#

multicast routing-enable

#

bfd

#

interface Vlanif302

ip address 10.1.3.2 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif304

ip address 10.1.5.2 255.255.255.0

pim sm

pim bfd enable

ospf bfd enable

#

interface Vlanif400

ip address 10.1.6.2 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.6.253

vrrp vrid 2 virtual-ip 10.1.6.254

vrrp vrid 2 priority 120

vrrp vrid 2 preempt-mode timer delay 20

pim sm

pim bfd enable

igmp enable

ospf bfd enable

#

interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 500

#

interface GigabitEthernet1/0/0

port link-type trunk

port trunk allow-pass vlan 400

stp disable

#

interface GigabitEthernet2/0/1

eth-trunk 1

#

interface GigabitEthernet2/0/2

eth-trunk 1

#

interface GigabitEthernet2/0/3

eth-trunk 1

#

interface GigabitEthernet3/0/1

port link-type trunk

port trunk allow-pass vlan 304

#

interface GigabitEthernet3/0/2

port link-type trunk

port trunk allow-pass vlan 302

#

interface LoopBack1

ip address 4.4.4.4 255.255.255.255

pim sm

#

ospf 1

bfd all-interfaces enable

area 0.0.0.0

network 3.3.3.3 0.0.0.0

network 10.1.3.0 0.0.0.255

network 10.1.5.0 0.0.0.255

network 10.1.6.0 0.0.0.255

#

pim

c-bsr LoopBack1

c-rp LoopBack1

#

return

 
   

END