OceanStor 5600V3 Toolkit fails to upgrade software

Publication Date:  2015-11-11 Views:  487 Downloads:  0
Issue Description

In some cases it is impossible to upgrade 5600 V3 from V300R001 to V300R002 software or visa versa using OceanStor Toolkit. This situation may take place if OceanStor Toolkit is outdated, but new version supporting current software installed in storage is still not available, or if upgrade operation itself is not supported between two desired versions. The error messages may be as below:

Handling Process

In this conditions it is impossible to upgrade software, only reinstall it.

Caution !!! All storage configuration and data will be lost !!!

Do not use on systems with business data !!!

  1. Upload software packsge to  /home/permitdir on both controllers, using scp for example.
  2. Change cli to minisystem:

 

 

  1. In minisystem issue the following command:

 

If execution will be followed by error or terminal window will close, relogin and repeat execution.

 

4.       Return back to Developer mode cli and run command to clear configuration

 

change user_mode current_mode user_mode=developer 

clear configuration_data

 

 

Execution of command above will lead to system reboot. After about half an hour system will be ready for usage.

END