OSPF中NSSA区域的两种缺省路由区别

发布时间:  2015-12-15 浏览次数:  255 下载次数:  3
问题描述

在OSPF的NSSA区域中,如果希望到达自治系统外部的路由通过该区域的ASBR到达,而其它外部路由通过其它区域出去,这种情况该如何满足?

如果希望所有的外部路由只通过本区域NSSA的ASBR到达,这种情况该如何满足?

解决方案

如上图所示,AR1与AR2之间为area0骨干区域,AR2与AR3之间为NSSA区域,AR2为ABR,AR3为ASBR,AR1的g0/0/1接口的网段引入到AR1的OSPF中,AR1也为ASBR,各设备基本配置如下:

AR1:


#
interface GigabitEthernet0/0/0
ip address 10.1.12.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 1.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 10.1.1.1 255.255.255.255
#
ospf 1 router-id 10.1.1.1
import-route direct route-policy direct
area 0.0.0.0
  network 10.1.12.0 0.0.0.255
#
route-policy direct permit node 10
if-match interface GigabitEthernet0/0/1
#

AR2:

#
interface GigabitEthernet0/0/0
ip address 10.1.12.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.1.23.2 255.255.255.0
#
interface LoopBack0
ip address 10.1.1.2 255.255.255.255
#
ospf 1 router-id 10.1.1.2
area 0.0.0.0
  network 10.1.12.0 0.0.0.255
area 0.0.0.2
  network 10.1.23.0 0.0.0.255
  nssa
#

AR3:

#
interface GigabitEthernet0/0/0
ip address 10.1.23.3 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.1.34.3 255.255.255.0
#
interface LoopBack0
ip address 10.1.1.3 255.255.255.255
#
ospf 1 router-id 10.1.1.3
area 0.0.0.2
  network 10.1.23.0 0.0.0.255
  nssa
#

AR4:

#
interface GigabitEthernet0/0/0
ip address 10.1.34.4 255.255.255.0
#

(1)在NSSA区域中,如果希望到达自治系统外部的路由通过该区域的ASBR(AR3)到达,而其他外部路由通过其他区域出去,那么ABR(AR2)会自动产生一条Type7 LSA的缺省路由,通告到整个NSSA区域内,而不论ABR的路由表上是否有缺省路由,如下图红色线所示。

(2)如果希望所有的外部路由只通过本区域NSSA的ASBR到达,则可以进行如下操作:

AR3:

#
ospf 1 router-id 10.1.1.3
area 0.0.0.2
  nssa default-route-advertise
#
ip route-static 0.0.0.0 0.0.0.0 10.1.34.4
#

nssa default-route-advertise:发布缺省路由到普通OSPF区域,这时候可以观察AR3的路由表和lsdb数据库如下:

AR3的路由表中存在缺省路由0.0.0.0,而ASBR(AR3)则产生一条Type7 LSA的缺省路由。






END